Bug 617247 - cman_tool - display meaningful translation of corosync exit code on exit
cman_tool - display meaningful translation of corosync exit code on exit
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Fabio Massimo Di Nitto
Cluster QE
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 11:16 EDT by Jan Friesse
Modified: 2016-04-26 09:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: cluster-3.0.12-27.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.63 KB, patch)
2010-07-22 11:38 EDT, Jan Friesse
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0537 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2011-05-18 13:57:40 EDT

  None (edit)
Description Jan Friesse 2010-07-22 11:16:24 EDT
Description of problem:
If cman_tool join runs corosync and that exit with failure, something like "Error, reason code is 12" is displayed. It should be nice to display something more meaningful like openais in RHEL5 does.

Version-Release number of selected component (if applicable):
git stable3

How reproducible:
100%

Steps to Reproduce (really example, same is with no memory error, ...):
1. rm -rf /var/lib/corosync
2. cman_tool join
  
Actual results:
corosync died: Error, reason code is 16

Expected results:
corosync died: Error, Required directory not present /var/lib/corosync.  Please create it.

Additional info:
There are other exit codes and none of them is handled correctly.

Main reason is because old aisexec returned negative return codes (or from other side, very big positive numbers ;) ). Current corosync return only (small) positive numbers.
Comment 2 Jan Friesse 2010-07-22 11:38:35 EDT
Created attachment 433735 [details]
Proposed patch

Patch handles corosync exit codes.
Comment 3 RHEL Product and Program Management 2010-07-22 11:38:58 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Jan Friesse 2010-09-29 06:26:07 EDT
Patch is currently included in STABLE3 git tree as 2197cb026309d18b864dd2eb10754b095090db40
Comment 7 errata-xmlrpc 2011-05-19 09:03:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0537.html

Note You need to log in before you can comment on or make changes to this bug.