Bug 617277 - subscription-manager unregister not removing key.pem
subscription-manager unregister not removing key.pem
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
Depends On:
Blocks: 568421
  Show dependency treegraph
 
Reported: 2010-07-22 12:21 EDT by wes hayutin
Modified: 2010-10-05 16:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 16:16:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-07-22 12:21:02 EDT
[root@oldceremony ~]# subscription-manager-cli unregister
[root@oldceremony ~]# subscription-manager-cli register --username=pascal.catric@a-sis.com --pass=redhat 
This system is already registered. Use --force to override
[root@oldceremony ~]# rpm -q subscription-manager
subscription-manager-0.71-1.el6.i686
[root@oldceremony ~]# ls /etc/pki/entitlement/product/
[root@oldceremony ~]# ls /etc/pki/entitlement/
key.pem  product
[root@oldceremony ~]#
Comment 1 Bryan Kearney 2010-08-03 17:18:02 EDT
Aainst latest (8cfc68209b2286a3738c6656b189d992ebf4b158) did the following:

./rhsm/subscription-manager-cli register --username admin --password admin --force
./rhsm/subscription-manager-cli subscribe --pool=3
ls /etc/pki/entitlement/ (see key.pem)
./rhsm/subscription-manager-cli unregister
ls /etc/pki/entitlement/ 

Directory does not exist.
Comment 2 wes hayutin 2010-08-09 17:49:41 EDT
I see this periodically, leaving on_qa
Comment 3 John Sefler 2010-09-08 12:04:25 EDT
I WAS NOT ABLE TO REPRODUCE THIS BUG.  THE unregister IS REMOVING THE key.pem.
Leaving ON_QA for now since Comment #2 claims to see this periodically.

[root@jsefler-rhel6-client01 ~]# rpm -q subscription-manager
subscription-manager-0.75-1.git.29.c3b1d88.fc12.i386


[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement
product
[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement/product/
[root@jsefler-rhel6-client01 ~]# subscription-manager-cli register --username=admin --password=admin
97d030fc-cbf4-467b-9b3c-3446decc392a admin
[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement/
product
[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement/product/
[root@jsefler-rhel6-client01 ~]# subscription-manager-cli subscribe --pool=3
[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement/
key.pem  product
[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement/product/
173.pem
[root@jsefler-rhel6-client01 ~]# subscription-manager-cli unregister
[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement/
ls: cannot access /etc/pki/entitlement/: No such file or directory
[root@jsefler-rhel6-client01 ~]# subscription-manager-cli register --username=admin --password=admin
4a7549b2-d59c-41cd-bf76-993f43f35f57 admin
[root@jsefler-rhel6-client01 ~]# ls /etc/pki/entitlement/
product
[root@jsefler-rhel6-client01 ~]#
Comment 4 Jeff Weiss 2010-10-05 16:16:51 EDT
I cannot reproduce this either.  Closing.

Note You need to log in before you can comment on or make changes to this bug.