Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617322 - [abrt] kernel: WARNING: at mm/highmem.c:444 debug_kmap_atomic+0x137/0x1b0() (Tainted: G M W )
[abrt] kernel: WARNING: at mm/highmem.c:444 debug_kmap_atomic+0x137/0x1b0() (...
Status: CLOSED DUPLICATE of bug 667565
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
abrt_hash:753841792
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 15:04 EDT by Jeff Layton
Modified: 2014-06-18 03:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-03 09:41:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.58 KB, text/plain)
2010-07-22 15:04 EDT, Jeff Layton
no flags Details
File: backtrace (1.92 KB, text/plain)
2011-03-01 15:46 EST, Red Hat Case Diagnostics
no flags Details

  None (edit)
Description Jeff Layton 2010-07-22 15:04:33 EDT
abrt version: 1.1.10
architecture: i686
Attached file: backtrace
cmdline: not_applicable
component: kernel
executable: kernel
kernel: 2.6.32-44.el6.i686
package: kernel
reason: WARNING: at mm/highmem.c:444 debug_kmap_atomic+0x137/0x1b0() (Tainted: G   M    W )
release: Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)
time: 1279825304
uid: 0

How to reproduce
-----
Nothing special. Just using machine as desktop with compiz enabled.
Comment 1 Jeff Layton 2010-07-22 15:04:35 EDT
Created attachment 433780 [details]
File: backtrace
Comment 2 Jeff Layton 2010-07-22 15:10:22 EDT
Adding Ben and Dave since this looks display driver related.

I've seen this with the -44.el6 kernel (with the patch to add support for single CRTC devices), but also with a -52.el6:

WARNING: at mm/highmem.c:444 debug_kmap_atomic+0x137/0x1b0() (Tainted: G   M    W )
Hardware name: 808625U
Modules linked in: fuse nfs lockd fscache nfs_acl auth_rpcgss autofs4 sunrpc p4_clockmod ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 iptable_filter ip_tables ip6t_REJECT nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables ipv6 dm_mirror dm_region_hash dm_log uinput ppdev parport_pc parport e1000 sg snd_intel8x0 snd_ac97_codec ac97_bus snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc i2c_i801 iTCO_wdt iTCO_vendor_support ext4 mbcache jbd2 sr_mod cdrom sd_mod crc_t10dif ata_generic pata_acpi ata_piix i915 drm_kms_helper drm i2c_algo_bit i2c_core video output dm_mod [last unloaded: microcode]
Pid: 0, comm: swapper Tainted: G   M    W  2.6.32-52.el6.i686 #1
Call Trace:
 [<c044fd87>] ? warn_slowpath_common+0x77/0xb0
 [<c04f2757>] ? debug_kmap_atomic+0x137/0x1b0
 [<c044fdd3>] ? warn_slowpath_null+0x13/0x20
 [<c04f2757>] ? debug_kmap_atomic+0x137/0x1b0
 [<c043677a>] ? kmap_atomic_prot+0x8a/0x150
 [<c043685c>] ? kmap_atomic+0x1c/0x30
 [<f802afcb>] ? i915_error_object_create+0xfb/0x1e0 [i915]
 [<f802b8d7>] ? i915_handle_error+0x827/0xa80 [i915]
 [<c0479edd>] ? do_gettimeofday+0xd/0x30
 [<f802be65>] ? i915_driver_irq_handler+0x205/0x400 [i915]
 [<c0425363>] ? lapic_next_event+0x13/0x20
 [<c047e01c>] ? clockevents_program_event+0x8c/0x120
 [<c04ad885>] ? handle_IRQ_event+0x45/0x140
 [<c04af98f>] ? handle_fasteoi_irq+0x5f/0xd0
 [<c040c192>] ? handle_irq+0x32/0x60
 [<c040b7c7>] ? do_IRQ+0x47/0xc0
 [<c0474b70>] ? hrtimer_start+0x20/0x30
 [<c040a0f0>] ? common_interrupt+0x30/0x38
 [<c04112dd>] ? mwait_idle+0x4d/0x90
 [<c0408884>] ? cpu_idle+0x94/0xd0
 [<c08090cb>] ? start_secondary+0x20f/0x254
---[ end trace dbc1b4e94e5920a3 ]---
Comment 4 RHEL Product and Program Management 2010-07-22 16:58:09 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Dave Airlie 2010-07-25 19:42:55 EDT
Is this the 865 machine?

Intel have nearly given up on supporting X on those from what I can see upstream, they seem to have a lot of issues and I'm not sure how well we can support acceleration on them going forward, I suppose I could turn it off for EL6.
Comment 6 Jeff Layton 2010-07-26 11:29:55 EDT
Yes, it's the 865 machine. I can provide access to it if it helps...
Comment 7 Jeff Layton 2010-07-26 11:31:21 EDT
FWIW, the relevant lspci info:

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
	Subsystem: IBM Device 02d2
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
	Region 1: Memory at e8000000 (32-bit, non-prefetchable) [size=512K]
	Region 2: I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915
Comment 8 RHEL Product and Program Management 2010-08-18 17:26:52 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.
Comment 9 J.H.M. Dassen (Ray) 2010-10-07 03:58:17 EDT
Created attachment 452051 [details]
sosreport of another affected system

I'm seeing a very similar backtrace with RC-4 on one of my test systems; it is captured in this sosreport's var/log/messages .
Comment 10 Red Hat Case Diagnostics 2011-03-01 15:46:17 EST
Created attachment 481715 [details]
File: backtrace
Comment 12 Dave Airlie 2011-03-01 18:04:20 EST
I'm not saying we can't support Intel 8xx but there would want to be a major need for us to investigate and fixes issues on this hardware, which is close to 7-8 years old.
Comment 13 Jeff Layton 2011-03-02 07:12:55 EST
Could it be that we just need this patch? The problem seems to be that the kmap slot is wrong:

commit 788885ae7a298dec73ba999c2fc5d46d42072ddf
Author: Andrew Morton <akpm@linux-foundation.org>
Date:   Tue May 11 14:07:05 2010 -0700

    drivers/gpu/drm/i915/i915_irq.c:i915_error_object_create(): use correct kmap-atomic slot
    
    i915_error_object_create() is called from the timer interrupt and hence
    can corrupt the KM_USER0 slot.  Use KM_IRQ0 instead.
    
    Reported-by: Jaswinder Singh Rajput <jaswinderlinux@gmail.com>
    Tested-by: Jaswinder Singh Rajput <jaswinderlinux@gmail.com>
    Acked-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: Dave Airlie <airlied@linux.ie>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 14 Dave Airlie 2011-03-02 16:01:35 EST
that should be in kernel > 117 and will be in 6.1
Comment 15 Jeff Layton 2011-03-02 16:21:44 EST
Excellent. I'll plan to test out the newer kernel tomorrow when I'll be near the machine.
Comment 16 Jeff Layton 2011-03-03 09:41:12 EST
So far, so good...

I upgraded my machine to -118 today and I no longer see these warnings. Usually I'd get them within an hour or so of normal desktop usage. I'm going to go ahead and close this as a duplicate of the bug under which that patch was committed.

*** This bug has been marked as a duplicate of bug 667565 ***

Note You need to log in before you can comment on or make changes to this bug.