Bug 617331 - Providing native systemd file for upcoming F14 Feature Systemd
Providing native systemd file for upcoming F14 Feature Systemd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: portreserve (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 697676 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2010-07-22 15:15 EDT by Jóhann B. Guðmundsson
Modified: 2011-07-12 12:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: portreserve-0.0.5-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-12 12:08:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd file for portreserve (323 bytes, text/plain)
2010-07-22 15:15 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2010-07-22 15:15:07 EDT
Created attachment 433787 [details]
Native systemd file for portreserve

Description of problem:

The attached file is a native systemd file for upcoming F14 Feature [1]

Please read [2] on how to installing systemd Service files.

1.http://fedoraproject.org/wiki/Features/systemd
2.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/Daemon#Installing_Systemd_Service_Files

If you have any question dont hesitate to ask them on this bug report.

Thank you. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2010-07-23 06:02:51 EDT
Actually I think systemd might make portreserve redundant.
Comment 2 Bug Zapper 2010-07-30 08:45:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Lennart Poettering 2010-08-11 09:54:20 EDT
Yepp, systemd will make portreserve redundant, if everybody who currently uses portreserve adopts socket based activation.

I guess we should indeed spend our energy on fixing those package to use socket-based activation instead of fixing portreserve itself for systemd.

So this bug is very low priority.
Comment 4 Tim Waugh 2011-04-19 09:05:00 EDT
*** Bug 697676 has been marked as a duplicate of this bug. ***
Comment 5 Jóhann B. Guðmundsson 2011-04-19 09:24:20 EDT
So.. What's the status on things now half a year later?
Comment 6 Tim Waugh 2011-04-19 09:35:41 EDT
It's still a very low priority bug.
Comment 7 Bill Nottingham 2011-04-26 13:35:44 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 8 Jóhann B. Guðmundsson 2011-06-23 06:44:40 EDT
Tim unfortunately this one is one the default livecd hence we need somekind of action either ported and packaged or deprecated before alpha otherwise this will become an alpha blocker...
Comment 9 Tim Waugh 2011-06-24 05:30:46 EDT
OK, understood.
Comment 10 Tim Waugh 2011-06-29 11:49:09 EDT
Going to deprecate it I think.  With systemd it doesn't really make sense any more.  systemd already binds the ports early and so avoids the problem.
Comment 11 Tim Waugh 2011-07-12 12:08:17 EDT
portreserve-0.0.5-3.fc16 now uses a systemd service file, so it isn't so important to deprecate it now.  Packages will naturally no longer need it once they are migrated to systemd.

Note You need to log in before you can comment on or make changes to this bug.