Bug 617333 - Providing native systemd file for upcoming F14 Feature Systemd
Providing native systemd file for upcoming F14 Feature Systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-updatesd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2010-07-22 15:16 EDT by Jóhann B. Guðmundsson
Modified: 2011-09-30 15:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: yum-updatesd-0.9-8.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd file for yum-updatesd (150 bytes, text/plain)
2010-07-22 15:16 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2010-07-22 15:16:52 EDT
Created attachment 433789 [details]
Native systemd file for yum-updatesd

Description of problem:

The attached file is a native systemd file for upcoming F14 Feature [1]

Please read [2] on how to installing systemd Service files.

1.http://fedoraproject.org/wiki/Features/systemd
2.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/Daemon#Installing_Systemd_Service_Files

If you have any question dont hesitate to ask them on this bug report.

Thank you. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2010-07-30 08:45:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Lennart Poettering 2010-08-10 10:00:26 EDT
ping
Comment 3 Bill Nottingham 2011-04-26 13:35:32 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 4 Jóhann B. Guðmundsson 2011-06-27 13:28:09 EDT
What's the current status on this?

We need this in rawhide as soon as possible unless ofcourse you guys want to
block alpha.. 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
http://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 5 Fedora Update System 2011-09-08 11:02:50 EDT
yum-updatesd-0.9-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-updatesd-0.9-6.fc16
Comment 6 Fedora Update System 2011-09-08 16:49:07 EDT
Package yum-updatesd-0.9-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-updatesd-0.9-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yum-updatesd-0.9-6.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-09-09 11:56:22 EDT
yum-updatesd-0.9-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-updatesd-0.9-8.fc16
Comment 8 Fedora Update System 2011-09-30 15:24:58 EDT
yum-updatesd-0.9-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.