Bug 617345 - Internal Server Error in webdev - when trying to apply errata to system.
Internal Server Error in webdev - when trying to apply errata to system.
Status: CLOSED DUPLICATE of bug 678550
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
low Severity medium
: ---
: ---
Assigned To: rhn-dev-list
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 15:39 EDT by venkat
Modified: 2011-02-18 06:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 06:55:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description venkat 2010-07-22 15:39:53 EDT
Description of problem:

Internal Server Error in webdev - when trying to apply errata to system.

Version-Release number of selected component (if applicable):


How reproducible:
this happend only once trying to run SSM Errata Test - SSMSystemTest->testSSMErrata 

here is the stack trace from the server logs: 

[Thu Jul 22 14:28:02 2010] [error] Execution of /var/www/html/network/systems/ssm/errata/index.pxt failed at Thu Jul 22 14:28:02 2010: RHN::Exception: DBD::Oracle::st execute failed: ORA-00001: unique constraint (RHN.RHN_SET_USER_LABEL_ELEM_UNQ) violated (DBD ERROR: OCIStmtExecute) [for Statement "INSERT INTO rhnSet (user_id, label, element, element_two) VALUES (?, ?, ?, ?)" with ParamValues: :p3='9953', :p1="5260506", :p4=undef, :p2='errata_list']\n  RHN::DB /usr/lib/perl5/site_perl/5.8.8/RHN/DB.pm 203 RHN::Exception::DB::throw\n  RHN::DB::Set /usr/lib/perl5/site_perl/5.8.8/RHN/DB/Set.pm 171 RHN::DB::handle_error\n  Sniglets::ListView::List /usr/lib/perl5/site_perl/5.8.8/Sniglets/ListView/List.pm 346 RHN::DB::Set::commit\n  Sniglets::Lists /usr/lib/perl5/site_perl/5.8.8/Sniglets/Lists.pm 122 Sniglets::ListView::List::callback\n  PXT::ApacheHandler /usr/lib/perl5/site_perl/5.8.8/PXT/ApacheHandler.pm 667 Sniglets::Lists::listview_cb\n  PXT::ApacheHandler /usr/lib/perl5/site_perl/5.8.8/PXT/ApacheHandler.pm 108 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /usr/lib/perl5/site_perl/5.8.8/PXT/ApacheHandler.pm 108 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)\n\nOffending Query: INSERT INTO rhnSet (user_id, label, element, element_two) VALUES (?, ?, ?, ?)
[Thu Jul 22 14:28:03 2010] [error] Traceback sent to rhn-traceback@rhn.redhat.com at /usr/lib/perl5/site_perl/5.8.8/PXT/ApacheHandler.pm line 775.
[Thu Jul 22 14:31:49 2010] [error] Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/site_perl/5.8.8/Sniglets/ListView/List.pm line 283.
[Thu Jul 22 14:31:49 2010] [error] Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/site_perl/5.8.8/Sniglets/ListView/List.pm line 284.
[Thu Jul 22 14:35:36 2010] [error] Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/site_perl/5.8.8/Sniglets/ListView/List.pm line 283.
/5.8.8/Sniglets/ListView/List.pm line 284.

Steps to Reproduce:

we are not able to reproduce this problem again.

  
Actual results:


Expected results:


Additional info:
Comment 1 Sebastian Skracic 2011-02-18 06:55:18 EST
This is the same race condition regarding the rhnSet management in Perl tier as in bug 678550, so closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 678550 ***

Note You need to log in before you can comment on or make changes to this bug.