Bug 617357 - QMF: python console discards broker connection failure information.
Summary: QMF: python console discards broker connection failure information.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf   
(Show other bugs)
Version: beta
Hardware: All
OS: Linux
low
high
Target Milestone: 1.3
: ---
Assignee: Ken Giusti
QA Contact: Frantisek Reznicek
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 615883
TreeView+ depends on / blocked
 
Reported: 2010-07-22 19:58 UTC by Ken Giusti
Modified: 2015-11-16 01:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken Giusti 2010-07-22 19:58:30 UTC
Description of problem:

Should its connection to the broker fail, the python QMF console may discard the reason for the failure.  Instead, the console prints:

Exception: Unknown connection exception

rather than the actual error description.
 
Version-Release number of selected component (if applicable):

How reproducible:
Occasional.

Steps to Reproduce:
1.  See https://bugzilla.redhat.com/show_bug.cgi?id=615883
2.
3.
  
Actual results:

Unknown connection exception displayed.


Expected results:

The actual reason for the failure should be displayed.

Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=615883

Comment 1 Ken Giusti 2010-07-22 20:25:18 UTC
Fixed upstream: Committed revision 965927.

http://svn.apache.org/viewvc?view=revision&revision=965927

Comment 3 Frantisek Reznicek 2010-07-27 10:15:33 UTC
The issue has been fixed, verified on RHEL4.8 / 5.5 i386 / x86_64 on packages:
python-qpid-0.7.946106-9.el5
qpid-cpp-client-*0.7.946106-10.el5
qpid-cpp-mrg-debuginfo-0.7.946106-9.el5
qpid-cpp-server-*0.7.946106-10.el5
qpid-java-client-0.7.946106-6.el5
qpid-java-common-0.7.946106-6.el5
qpid-tools-0.7.946106-7.el5
rh-qpid-cpp-tests-0.7.946106-10.el5

-> VERIFIED


Note You need to log in before you can comment on or make changes to this bug.