Bug 617366 - PackageKit-browser-plugin doesn't find PackageKit by dbus
PackageKit-browser-plugin doesn't find PackageKit by dbus
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: PackageKit (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 16:48 EDT by Hugo Melo
Modified: 2012-02-03 04:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-03 04:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test file used to get the error. (1.30 KB, text/html)
2010-07-22 17:33 EDT, Hugo Melo
no flags Details

  None (edit)
Description Hugo Melo 2010-07-22 16:48:24 EDT
Description of problem:

cat /etc/redhat-release
Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)
hugo@REDHAT temp$:rpm -qa \*PackageKit\*
PackageKit-yum-0.5.8-7.el6.x86_64
PackageKit-browser-plugin-0.5.8-7.el6.x86_64
PackageKit-0.5.8-7.el6.x86_64
PackageKit-device-rebind-0.5.8-7.el6.x86_64
PackageKit-gstreamer-plugin-0.5.8-7.el6.x86_64
PackageKit-gtk-module-0.5.8-7.el6.i686
PackageKit-gtk-module-0.5.8-7.el6.x86_64
PackageKit-glib-0.5.8-7.el6.x86_64
PackageKit-yum-plugin-0.5.8-7.el6.x86_64

uname -a
Linux localhost.localdomain 2.6.32-44.1.el6.x86_64 #1 SMP Wed Jul 14 18:51:29 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Everytime.

Steps to Reproduce:
1. Open Firefox using: (firefox -g)
2. Open the html example attached (test.html)
3. Click on Lynx for installing it.
  
Actual results:
It doesn't install the package and prints the error message below in the terminal:
FN:pk-plugin-install.c FC:pk_plugin_install_method_finished_cb LN:927
!!      Error occurred during install: The name org.freedesktop.PackageKit was not provided by any .service files


Expected results:
Expected to install the package.

Additional info:
Comment 2 RHEL Product and Program Management 2010-07-22 17:17:40 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Hugo Melo 2010-07-22 17:33:44 EDT
Created attachment 433815 [details]
test file used to get the error.
Comment 4 John Walicki 2010-07-23 01:51:32 EDT
This feature is important to IBM's deployment of Linux packages.
Comment 5 Richard Hughes 2010-07-23 04:23:42 EDT
Is gnome-packagekit installed? Is the gpk-update-icon process running?  The org.freedesktop.PackageKit service referred to is the session instance, not the system instance. Looking at the debug output, it could be the session instance crashed, although I would have expected it to be a bit more vocal doing so.

Assuming a fresh login session has the gpk-update-icon process running, could you please:

killall gpk-update-icon
gpk-update-icon --verbose

and then do the install in the browser to reproduce the error. This should print a few pages of debugging in the gpk-update-icon process terminal.

If it crashes, then a gdb backtrace (with debuginfo packages installed) would be very useful. Thanks.
Comment 6 Hugo Melo 2010-07-23 15:29:07 EDT
Richard,
This bug was caused because gpk-update-icon was not running when I first tested the plugin. That happened because I was using KDE for testing it. 
When I saw your comments I went to test using gnome. gpk-update-icon was running and the plugin was able to install the package.
Maybe you want to work on this KDE issue later. It's not a big issue to me and IBM. But testing with gnome I got the old issues I've reported to you in some other tickets like this:
https://bugzilla.redhat.com/show_bug.cgi?id=587117
I am submitting another bug report with the information I got with debuginfo.
Thanks!
Comment 7 Hugo Melo 2010-07-23 15:39:18 EDT
If it helps, there's another bug ticket opened:
https://bugzilla.redhat.com/show_bug.cgi?id=547113
Thanks!
Comment 8 Hugo Melo 2010-07-23 17:16:19 EDT
I opened another ticket with RHEL6 debug information.
https://bugzilla.redhat.com/show_bug.cgi?id=617734
Comment 9 RHEL Product and Program Management 2010-08-18 17:20:03 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.
Comment 10 Richard Hughes 2012-02-03 04:27:40 EST
(In reply to comment #6)
> Maybe you want to work on this KDE issue later. It's not a big issue to me and
> IBM.

Right; there now exists a kpackagekit project that provides the same session interface as the gnome session helper. It's probably not suitable for RHEL6, but upstream it's certainly solved now.

I'll close this NOTABUG now, but you might want to look at how backportable kpackagekit is if you want to use it internally. Thanks.

Note You need to log in before you can comment on or make changes to this bug.