Bug 617374 - fc14 rpm init script broken
fc14 rpm init script broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: inadyn-mt (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 17:11 EDT by Bryan Hoover
Modified: 2010-11-29 17:43 EST (History)
1 user (show)

See Also:
Fixed In Version: fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-29 17:43:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Hoover 2010-07-22 17:11:35 EDT
Description of problem:

inadyn-mt-2_18_36-1_fc14

package init script looks for configuration file /etc/inadyn.conf though the spec file, in accordance with upstream search algorithm changes, installs only inadyn-mt.conf.  New, systemd related start up considerations not withstanding, this renders program start up broken.

Having upgraded my download repositories to rawhide, and attempted a Fedora upgrade (success with dependency problems), was able to install the inadyn-mt fc14 package via yum.  Systemd did not install so was not in use.  

I was not able to start inadyn-mt until I corrected the init script, /etc/rc.d/init.d/inadyn

Version-Release number of selected component (if applicable):

inadyn-mt-2_18_36-1_fc14

How reproducible:

Install via yum, and attempt start via init script.

Steps to Reproduce:
1.  install inadyn-mt:  yum -i inadyn-mt

2.  run init:  /etc/init.d/inadyn start
No statup confirmation output is displayed.

3.  verify start:  ps -e|grep inadyn
inadyn process does not appear in ps process list.
  
Actual results:

1.  install without problem

2.  no startup confirmation output is displayed.

3.  inadyn process does not appear in ps process list.

Expected results:

1.  install without problem

2.  output string indicating inadyn was successfully started

3.  inadyn process should appear in ps process list.


Additional info:

spec file should also probably check if sym link for any existing /etc/inadyn.conf.

The service in the units rpm is named inadyn-mt, though the init script in /etc/init.d is name inadyn (though the exec command statement is correct, as /usr/sbin/inadyn.

Since inadyn-mt, now at version 2.18.36, has not been upgraded in Fedora since its acceptance in Fedora 10, as inadyn-mt.v.02.12.24, it would be nice if this could be cleared up in time for changes freeze to come in less than a week.
Comment 1 Bug Zapper 2010-07-30 08:46:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.