Bug 617376 - [abrt] crash in deskbar-applet-2.30.0-2.fc13: decoder.py:338:raw_decode:ValueError: No JSON object could be decoded
Summary: [abrt] crash in deskbar-applet-2.30.0-2.fc13: decoder.py:338:raw_decode:Value...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: deskbar-applet   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:42960288
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-22 21:17 UTC by Isaac
Modified: 2016-09-20 02:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 21:35:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.61 KB, text/plain)
2010-07-22 21:17 UTC, Isaac
no flags Details

Description Isaac 2010-07-22 21:17:17 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: python /usr/libexec/deskbar-applet/deskbar-applet --oaf-activate-iid=OAFIID:Deskbar_Applet_Factory --oaf-ior-fd=22
component: deskbar-applet
executable: /usr/libexec/deskbar-applet/deskbar-applet
kernel: 2.6.33.6-147.fc13.x86_64
package: deskbar-applet-2.30.0-2.fc13
reason: decoder.py:338:raw_decode:ValueError: No JSON object could be decoded
release: Fedora release 13 (Goddard)

backtrace
-----
decoder.py:338:raw_decode:ValueError: No JSON object could be decoded

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/deskbar/gtkexcepthook.py", line 73, in run
    run_old(*args, **kwargs)
  File "/usr/lib64/python2.6/threading.py", line 477, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.6/site-packages/deskbar/core/ThreadPool.py", line 67, in _worker
    function(*args, **kwargs)
  File "/usr/libexec/deskbar-applet/modules-2.20-compatible/googlesearch.py", line 159, in query
    jsondata = json.loads(stream.read())
  File "/usr/lib64/python2.6/json/__init__.py", line 307, in loads
    return _default_decoder.decode(s)
  File "/usr/lib64/python2.6/json/decoder.py", line 319, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib64/python2.6/json/decoder.py", line 338, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded

Local variables in innermost frame:
s: '<HTML>\r\n<TITLE></TITLE>\r\n<BODY onLoad="document.forms[0].submit();">\r\n<FORM METHOD="POST" ACTION="/login">\r\n<INPUT TYPE="HIDDEN" NAME="AP_MAC" VALUE="0003520B26F7">\r\n<INPUT TYPE="HIDDEN" NAME="CLIENT_IP" VALUE="10.0.0.50">\r\n<INPUT TYPE="HIDDEN" NAME="CLIENT_MAC" VALUE="00-26-08-DF-F8-78">\r\n<INPUT TYPE="HIDDEN" NAME="loginURL" VALUE="https://portals.wanderingwifi.com:8090/goform/HtmlLoginRequest">\r\n<INPUT TYPE="HIDDEN" NAME="P_H_" VALUE="1">\r\n</BODY>\r\n</HTML>\r\n\r\n'
kw: {'context': <json.decoder.JSONDecoder object at 0x12af390>, 'idx': 0}
self: <json.decoder.JSONDecoder object at 0x12af390>

How to reproduce
-----
1. Booted into Fedora
2. Logged into Gnome Desktop
3.

Comment 1 Isaac 2010-07-22 21:17:21 UTC
Created attachment 433808 [details]
File: backtrace

Comment 2 Luke Macken 2010-07-22 21:35:44 UTC
It looks like you're on a wireless network that requires some sort of login/registration -- thus deskbar is getting an unexpected response from this 'portals.wanderingwifi.com' instead of from google.com.


Note You need to log in before you can comment on or make changes to this bug.