Bug 61738 - Installer installs & configures grub for smp kernel on uniproc machine
Installer installs & configures grub for smp kernel on uniproc machine
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-23 16:19 EST by Christopher Barton
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-23 18:32:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Barton 2002-03-23 16:19:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
When installing skipjack, Anaconda installs and configures grub for the smp kernel.

My machine has a single CPU.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install skipjack
2. Reboot
3. Grub shows kernel-smp as default
	

Actual Results:  kernel-smp is configured to boot by default

Expected Results:  kernel should be configured to boot

Additional info:

[root@bishop root]# cat anaconda-ks.cfg
# Kickstart file automatically generated by anaconda.

install
lang en_US
langsupport --default en_US en_US
keyboard us
mouse msintellips/2 --device psaux
xconfig --card "ATI Rage 128" --videoram 16384 --hsync 30.0-95.0 --vsync
50.0-160.0 --resolution 1400x1050 --depth 32
network --device eth0 --bootproto static --ip 10.0.0.3 --netmask 255.0.0.0
--gateway 10.0.0.1 --nameserver 10.0.0.1 --hostname bishop.infoglut.com
rootpw --iscrypted
firewall --disabled
authconfig --enableshadow --enablemd5
timezone --utc America/Chicago
bootloader --append hdc=ide-scsi
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --linux
#part / --fstype ext3 --size=4096
#part swap --size=1024

%packages
@ Printing Support
@ Classic X Window System
@ X Window System
@ GNOME
@ Sound and Multimedia Support
@ Network Support
@ Dialup Support
@ Messaging and Web Tools
@ Everything
kernel-smp

%post
Comment 1 Jeremy Katz 2002-03-23 17:28:53 EST
What are the contents of /proc/cpuinfo on this machine?
Comment 2 Christopher Barton 2002-03-23 18:27:43 EST
bishop ~% cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 0
model name      : Intel(R) Pentium(R) 4 CPU 1500MHz
stepping        : 10
cpu MHz         : 1495.166
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 2981.88
Comment 3 Christopher Barton 2002-03-23 18:32:08 EST
So is this due to hyperthreading?  If so, sorry & thanks....
Comment 4 Christopher Barton 2002-03-23 19:19:13 EST
OK, I found it in isys/smp.c.  Definitely due to hyperthreading.

I supposed others like me who lack a clue might appreciate having that in
RELEASE-NOTES.

Note You need to log in before you can comment on or make changes to this bug.