Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617380 - Sorting on column headers in history sub-view of group alerts is broken
Sorting on column headers in history sub-view of group alerts is broken
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
3.0.0
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: jon-sprint12-bugs
  Show dependency treegraph
 
Reported: 2010-07-22 17:21 EDT by John Sanda
Modified: 2010-09-28 08:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-28 08:17:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sanda 2010-07-22 17:21:50 EDT
Description of problem:
Generate some alerts for a group. Then go to,

group --> alerts --> history

Clicking on the 'Date Created' header should toggle sorting back and forth between ascending and descending order. Nothing happens though due to the following hibernate query exception,

ERROR [org.rhq.enterprise.gui.common.paging.PagedListDataModel] PageControlView[ListGroupAlertHistoryUIBean]: Received error[java.lang.IllegalArgumentException: org.hibernate.QueryException: could not resolve property: a of: org.rhq.core.domain.alert.Alert [SELECT alert
FROM org.rhq.core.domain.alert.Alert alert
LEFT JOIN FETCH alert.alertDefinition
WHERE ( alert.alertDefinition.resource.id IN ( :resourceIds ) )
ORDER BY alert.a.ctime ASC
]], resetting to PageControl[page=0, size=15]

This also happens when you click on the 'Priority' and 'Alert Definition' columns. This should be a quick fix on listGroupAlertHistory.xhtml.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Charles Crouch 2010-07-22 17:29:30 EDT
I dont see this as a release blocker at this stage, alert sorting still works at the individial resource level, but this should get fixed in master.
Comment 2 Corey Welton 2010-09-28 08:17:50 EDT
Closing per gwt effort

Note You need to log in before you can comment on or make changes to this bug.