Bug 617384 - Segfault in %check when building numpy against python 2.7
Segfault in %check when building numpy against python 2.7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 17:35 EDT by Dave Malcolm
Modified: 2010-07-22 19:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: numpy-1.4.1-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 19:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace from segfault (5.44 KB, text/plain)
2010-07-22 17:38 EDT, Dave Malcolm
no flags Details

  None (edit)
Description Dave Malcolm 2010-07-22 17:35:25 EDT
Description of problem:
Attemping to rebuild numpy against 2.7 thus:
  koji build dist-f14-py27-rebuild $(make cvsurl)
(from tagged CVS checkout)

dies with a segfault in %check:
http://koji.fedoraproject.org/koji/getfile?taskID=2337411&name=build.log

I'll attach a backtrace.

I did some searching and found some references to porting numpy to 2.7
  http://mail.scipy.org/pipermail/numpy-discussion/2010-June/051207.html
  http://old.nabble.com/Numpy-1.5-for-Python-2.7-and-3.1-td28995808.html
  http://projects.scipy.org/numpy/ticket/1520

It's not clear to me what API/ABI approaches they're following, and is this is applicable to 1.4.1.

Version-Release number of selected component (if applicable):
numpy-1.4.1-4.fc14

How reproducible:
100%

Steps to Reproduce:
Simulate the %check from the build thus:
1. cd rpmbuild/BUILD/numpy-1.4.1/doc
2. PYTHONPATH=/root/rpmbuild/BUILDROOT/numpy-1.4.1-4.fc14.x86_64/usr/lib64/python2.7/site-packages gdb --args /usr/bin/python -c "import pkg_resources, numpy ; numpy.test()"

Unfortunately symbols have been stripped at this point; I wonder what the best way to regenerate this one is
Comment 1 Dave Malcolm 2010-07-22 17:38:02 EDT
Created attachment 433816 [details]
Backtrace from segfault
Comment 2 Dave Malcolm 2010-07-22 19:00:59 EDT
Seems to be this:
http://www.mail-archive.com/numpy-discussion@scipy.org/msg22626.html
Comment 4 Dave Malcolm 2010-07-22 19:11:06 EDT
changeset 8387 is layered on top of http://projects.scipy.org/numpy/changeset/7926/trunk/numpy/core/src/multiarray/numpyos.c
Comment 5 Dave Malcolm 2010-07-22 19:34:02 EDT
I've committed a version of this to CVS as numpy-1.4.1-6.fc14

Attempting a rebuild:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2343683
Comment 6 Dave Malcolm 2010-07-22 19:39:29 EDT
The build succeeded.

There are a lot of failures in the selftest in the %check, but that doesn't seem to stop the build:
see e.g. http://koji.fedoraproject.org/koji/getfile?taskID=2343685&name=build.log

> Ran 2395 tests in 10.666s
> FAILED (KNOWNFAIL=4, errors=9, failures=3)

and a lot of noise due to deprecation.  At least some of this seems to have been fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.