Bug 617388 - virt-manager UI blocks for 60+ seconds while connecting to remote hypervisor
virt-manager UI blocks for 60+ seconds while connecting to remote hypervisor
Status: CLOSED DUPLICATE of bug 607735
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 17:51 EDT by Máirín Duffy
Modified: 2010-11-23 15:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 15:22:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blocking virt manager ui (96.06 KB, image/png)
2010-07-22 17:51 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2010-07-22 17:51:52 EDT
Created attachment 433817 [details]
blocking virt manager ui

Description of problem:

- i have a remote hypervisor i'm trying to connect to
- it's a qemu/kvm hypervisor, i pick the ssh tunnel for connection, in the hostname field i put "root@thehostname"
- I hit connect
- over 60 seconds pass by my laptop's clock. The UI gets blocked up and virt-manager looks like it's crashed.
- it eventually comes back and connects to the remote hypervisor.

(see screenshot)

Version-Release number of selected component (if applicable):
virt-manager-0.8.4-7.el6.noarch

How reproducible:
very

Steps to Reproduce:
see steps above
Comment 2 RHEL Product and Program Management 2010-07-22 18:18:08 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Cole Robinson 2010-08-06 10:46:05 EDT
Hmm, was the remote machine over a VPN connection or some other slow link? Not seeing that kind of delay with a close proximity remote host.

Do you have a lot of VMs on the remote host? Does the app lock at all after connecting?
Comment 4 Máirín Duffy 2010-08-06 11:00:21 EDT
Hi Cole, I am in the Westford office as is the remote machine - it's in the lab here in the building. No VPN connection.

There are 4 or 5 VMs on the host, but 1 is shut-off. If the app doesn't completely lock up, it works fine after connecting. 

The UI really shouldn't block, right?.... some kind of progress indicator would be good just so it's clear the app hasn't died.
Comment 5 Máirín Duffy 2010-08-06 11:00:49 EDT
Oh actually I might have lied. I may have been on the wireless VPN in the office.
Comment 6 Cole Robinson 2010-11-23 15:22:08 EST

*** This bug has been marked as a duplicate of bug 607735 ***

Note You need to log in before you can comment on or make changes to this bug.