Bug 617389 - if remote hypervisor username different than local virt-manager client machine username, confusion ensues
Summary: if remote hypervisor username different than local virt-manager client machin...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: RHELNAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-22 21:56 UTC by Máirín Duffy
Modified: 2011-05-19 13:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 13:46:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the 'add connection' dialog (69.56 KB, image/png)
2010-07-22 21:56 UTC, Máirín Duffy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0637 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-05-18 17:55:47 UTC

Description Máirín Duffy 2010-07-22 21:56:40 UTC
Created attachment 433818 [details]
screenshot of the 'add connection' dialog

Description of problem:
my username on my local laptop on which i run virt-manager is duffy.
my access to the remote hypervisor on which my guests run is via the 'root' account, through my ssh key.

when i used the 'Add connection' dialog, this vital knowledge was not at the front of my mind. since the 'hostname' field is labeled 'hostname' i didn't not realize, once i thought that maybe the username was an issue, that you could type a username@ in the field.

i don't know what the right answer is though. maybe have a separate username field that defaults to the local username? or a tooltip that lets you know you can type usernames?

maybe suggest to users upon a failed connection that you tried to connect as 'duffy' but maybe should try as 'root'?

Version-Release number of selected component (if applicable):
virt-manager-0.8.4-7.el6.noarch

Comment 2 RHEL Product and Program Management 2010-07-22 22:17:51 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 Cole Robinson 2011-01-14 22:20:39 UTC
Fixed in virt-manager-0.8.6-1.el6.

Comment 5 zhanghaiyan 2011-03-02 07:46:02 UTC
Verified this bug PASS with virt-manager-0.8.6-2.el6.noarch

Separate input box (username, hostname) is provided for user and also a dynamic info at the below displaying 'Generated URI: qemu+ssh://$username@/system'

Comment 6 errata-xmlrpc 2011-05-19 13:46:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0637.html


Note You need to log in before you can comment on or make changes to this bug.