Bug 61740 - glob patterns match wrong case
glob patterns match wrong case
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-23 17:27 EST by Roland McGrath
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-23 17:27:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2002-03-23 17:27:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I am astonished.  Globbing has been broken.  Good trick.



Version-Release number of selected component (if applicable):

bash-2.05-8 glibc-2.2.4-19.3

How reproducible:
Always

Steps to Reproduce:
1.touch B
2.echo [a-c]*
3.See B in the list.
4.Marvel at the lossage.


Actual Results:  redhat 81 % touch B
redhat 82 % echo [a-c]*
B
redhat 83 % 

Expected Results:  [a-c] should not match B.  In my test, the output should be
empty.

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-03-23 19:30:19 EST
That's because bash is locale aware and you're using a case insensitive locale. 
If you don't like it, export LC_COLLATE=C 
If you want to get rid of it permanently, add LC_COLLATE=C to /etc/sysconfig/i18n. 

Note You need to log in before you can comment on or make changes to this bug.