Bug 61741 - Personal gnome config gets confused if user switches back and forth between versions
Personal gnome config gets confused if user switches back and forth between v...
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-23 17:53 EST by sdh4
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-23 17:53:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sdh4 2002-03-23 17:53:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
Often one configures a network to share home directories, and often not all of
the computers run the same version of linux. If a user logs into a 7.2 machine,
his configuration updates to gnome 1.4. If that user then tries to log into a
7.0 or 7.1 machine, the user's settings no longer work, and the user must clear
his .gnome directory and start over. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Share a home directory between a 7.2 machine and a 7.0 machine
2.Clear the .gnome directory
3.Log in to the 7.0 machine with gnome
4.Log in to the 7.2 machine with gnome
5.Log in to the 7.0 machine. You will see that the configuration has
been corrupted. 
	

Actual Results:  Configuring the gnome-1.4 damaged the configuration so it
wouldn't work
under 1.2

Expected Results:  Either the configurations should be compatible, or gnome 1.2
and 1.4
should use separate directories (e.g. .gnome-1.2 and .gnome-1.4) 
to store configuration information. This problem also occurred with
1.0 and 1.2, and may also occur with 2.0 unless it is fixed. 

Additional info:
Comment 1 Havoc Pennington 2002-03-23 18:11:25 EST
We are trying to fix for 2.0. The problem is that making this work involves
carefully monitoring all changes to config data and formats; so it's more an
education thing for all the open source developers involved than anything else.

Anyhow, there is no way to retroactively fix for 1.x, so closing the bug report; 
consider the point duly noted, though, and a best effort is being made to put
process in place to avoid this issue.

Note You need to log in before you can comment on or make changes to this bug.