Bug 617414 - avoid canceling in flight ide dma
avoid canceling in flight ide dma
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Andrea Arcangeli
Virtualization Bugs
:
: 618901 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 20:44 EDT by Andrea Arcangeli
Modified: 2010-11-11 14:30 EST (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.101.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:26:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Arcangeli 2010-07-22 20:44:09 EDT
Description of problem: in flight dma might be aborted partially

not reproducible found by code review and applied to RHEL6 KVM package but missing in RHEL6 because rejected by upstream.
Comment 1 Andrea Arcangeli 2010-07-22 20:46:33 EDT
Patch posted as Message-ID: <20100721152112.GZ24928@random.random> in rhvirt-patches.
Comment 2 Andrea Arcangeli 2010-07-22 20:56:27 EDT
rediffed and reposted to rhvirt-patches as Message-ID: <20100723005600.GU24928@random.random>
Comment 4 RHEL Product and Program Management 2010-07-22 21:17:37 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Amit Shah 2010-07-23 03:16:25 EDT
Andrea, can you note why this was rejected upstream?
Comment 7 Andrea Arcangeli 2010-07-23 10:21:33 EDT
I submitted it to Anthony last version on 26 Feb 2009 (you can check on qemu-devel archives) and got no answer simply and apparently it wasn't applied.
Comment 8 Amit Shah 2010-07-23 11:10:44 EDT
(In reply to comment #7)
> I submitted it to Anthony last version on 26 Feb 2009 (you can check on
> qemu-devel archives) and got no answer simply and apparently it wasn't applied.    

qemu upstream needs constant reminders; can you send out a rebased patch to the upstream list?
Comment 12 Kevin Wolf 2010-07-30 03:20:54 EDT
*** Bug 618901 has been marked as a duplicate of this bug. ***
Comment 13 Mike Cao 2010-07-30 06:16:58 EDT
Hi ,

Could you give me some suggestions how to verify this issue.?
Comment 14 Andrea Arcangeli 2010-07-30 09:21:17 EDT
Ok, I'm afraid there is no way to verify it. It's a "theoretical" fix for not easily reproducible issue.

The thing to verify is that this doesn't cause regressions, so you shall run some I/O intensive workload with the -drive if=ide and then run a e2fsck -f /dev/hd?? to verify the fileysystem is fine.
Comment 15 Mike Cao 2010-08-01 23:07:37 EDT
Verified in qemu-kvm-0.12.1.2-2.106.el6.x86_64.

Steps:
1.Since bug 618901 marked as dup of this one .Verified that bug and passed.

2.Following steps comment #14.and find no bad block inode.

Based on above ,this issue has already been fixed .
Change status to VERIFIED.
Comment 16 releng-rhel@redhat.com 2010-11-10 16:26:50 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.