Bug 617419 - libtool fails, missing echo
libtool fails, missing echo
Status: CLOSED WORKSFORME
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.2.6
All Other
low Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 21:11 EDT by Ulf Weltman
Modified: 2015-01-04 18:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 16:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulf Weltman 2010-07-22 21:11:17 EDT
libtool has started failing for me on HP-UX after this commit:
commit 4a489ebe942363f037030b295d1747af17c35fe6
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Thu Jul 22 16:00:36 2010 -0600
    fix build failures due to libtool problems

It seems $echo is undefined in libtool but I can't tell why.  It's causing statements like `$echo foo | $sed` to fail.

./libtool[824]: X--tag=CC:  not found.
./libtool[857]: libtool: ignoring unknown tag :  not found.
./libtool[824]: X--mode=compile:  not found.
./libtool[990]: *** Warning: inferring the mode of operation is deprecated.:  no
t found.
./libtool[991]: *** Future versions of Libtool will require --mode=MODE be speci
fied.:  not found.
./libtool[1021]: libtool: warning: cannot infer operation mode from `aCC':  not
found.
./libtool[7074]: libtool: you must specify a MODE:  not found.
./libtool[7075]: Try `libtool --help' for more information.:  not found.
Comment 1 Ulf Weltman 2010-07-22 21:16:53 EDT
I compared to a libtool from an earlier build and the new failure seems to happen because this line:
# An echo program that does not interpret backslashes.
echo="print -r"

Has become this:
# An echo program that does not interpret backslashes.
ECHO="print -r"

Any ideas?
Comment 2 Ulf Weltman 2010-07-23 16:11:34 EDT
Oops, Rich's checkin *fixes* this error, I didn't realize it wasn't checked into master so I didn't have the fix.  Pulling new configure after Noriko pushed to master fixes it.

Note You need to log in before you can comment on or make changes to this bug.