Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617447 - python-tg-devtools missing from RHEL6.0 beta
python-tg-devtools missing from RHEL6.0 beta
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: TurboGears2 (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Python Maintainers
qe-baseos-daemons
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 23:55 EDT by Luke Macken
Modified: 2016-09-19 22:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-05 01:56:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2010-07-22 23:55:42 EDT
Description of problem:

python-tg-devtools contains the SQLAlchemy migration commands and quickstart templates needed for developing and maintaining TurboGears2 applications.
This package is missing from RHEL6, yet the TurboGears2 package is present.
Comment 2 RHEL Product and Program Management 2010-07-23 00:17:37 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Bill Nottingham 2010-07-28 17:33:21 EDT
Should this be a dependency of TG2?
Comment 4 Luke Macken 2010-07-28 17:39:54 EDT
(In reply to comment #3)
> Should this be a dependency of TG2?    

I'm not quite sure.  TG2 apps should be able to run fine without this package.  The current dependency chain is based on how upstream defines it.
Comment 5 RHEL Product and Program Management 2011-01-07 10:57:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 Bohuslav "Slavek" Kabrda 2014-10-23 06:49:20 EDT
Luke, is this package still needed?
Looking into Fedora, the latest version seems to have bunch of deps that are not in RHEL 6, which would make adding this package pretty complicated. If it is still needed, could you please specify the lowest version (or the version with least dependencies) that you need?
Thanks!
Comment 7 Luke Macken 2014-11-04 11:05:06 EST
We no longer need python-tg-devtools in RHEL6 for anything in Fedora Infrastructure, since we're moving away from TurboGears. So, I'm happy to close this bug, however the TG2 stack is still pretty incomplete in RHEL6.
Comment 8 Bohuslav "Slavek" Kabrda 2014-11-05 01:56:26 EST
Thanks for the response. I'll close this for now - anyone can reopen if there is a need for this.

Note You need to log in before you can comment on or make changes to this bug.