Bug 617493 - Missing Device ID for Canon imageRunner C3170
Summary: Missing Device ID for Canon imageRunner C3170
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic-db (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: IEEE1284DeviceIDs
TreeView+ depends on / blocked
 
Reported: 2010-07-23 09:10 UTC by Jiri Popelka
Modified: 2010-11-03 15:58 UTC (History)
2 users (show)

Fixed In Version: foomatic-db-4.0-20.20100819.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-03 15:58:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (678 bytes, patch)
2010-07-23 09:38 UTC, Jiri Popelka
no flags Details | Diff

Description Jiri Popelka 2010-07-23 09:10:46 UTC
I see the Device ID in system-config-printer output when configuring network printer.

./check-device-ids.py "Canon imageRunner C3170" "MFG:Canon;MDL:iR 3170C EUR 35.01;DES:Canon iR 3170C EUR 35.01"
Fetching driver list
└── Canon imageRunner C3170 (user-specified): MFG:Canon;MDL:iR 3170C EUR 35.01;
    (No drivers)
        MISSING  foomatic:Canon-imageRunner_C3170-Postscript.ppd [/usr/lib/cups/driver/foomatic]
        MISSING  foomatic:Canon-imageRunner_C3170-hpijs.ppd [/usr/lib/cups/driver/foomatic]
        MISSING  foomatic:Canon-imageRunner_C3170-hpijs-pcl5c.ppd [/usr/lib/cups/driver/foomatic]

Version-Release number of selected component (if applicable):
foomatic-db-4.0-17.20100204.fc13.noarch

Comment 1 Jiri Popelka 2010-07-23 09:38:25 UTC
Created attachment 433905 [details]
fix

Comment 2 Fedora Update System 2010-08-19 13:15:48 UTC
foomatic-db-4.0-19.20100819.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/foomatic-db-4.0-19.20100819.fc13

Comment 3 Fedora Update System 2010-08-19 13:16:48 UTC
foomatic-db-4.0-19.20100819.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/foomatic-db-4.0-19.20100819.fc14

Comment 4 Fedora Update System 2010-08-20 02:24:13 UTC
foomatic-db-4.0-19.20100819.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/foomatic-db-4.0-19.20100819.fc13

Comment 5 Fedora Update System 2010-09-17 18:25:43 UTC
foomatic-db-4.0-20.20100819.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2010-09-23 12:35:10 UTC
foomatic-db-4.0-20.20100819.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Jiri Popelka 2010-11-02 20:27:30 UTC
We have 3 'Canon iR 3170C' here in Brno office.

One reports the Device ID as in comment #0:
$ /usr/lib/cups/backend/snmp 10.34.18.1
network socket://10.34.18.1 "Canon iR 3170C EUR 35.01" "Canon iR 3170C EUR 35.01" "" "2nd floor, entrance area"

But the 2 remaining report slightly different Device ID,
so system-config-printer-1.2.5 isn't able to auto-configure them.

$ /usr/lib/cups/backend/snmp 10.34.19.2
network socket://10.34.19.2 "Canon iR 3170C EUR 36.01" "Canon iR 3170C EUR 36.01" "" "3rd floor, near cafetaria"

$ /usr/lib/cups/backend/snmp 10.34.20.1
network socket://10.34.20.1 "Canon iR 3170C EUR 36.01" "Canon iR 3170C EUR 36.01" "" "5th floor"

Any idea how is this possible ?

Comment 8 Jiri Popelka 2010-11-03 10:45:01 UTC
(In reply to comment #7)
> Any idea how is this possible ?
They differ in 'Controller Version'

Controller Version : 	3501.901.1401
Controller Version : 	3601.901.1701


Reopening:

I'm not sure the fix was even necessary.
What the snmp backend returns is not device-id,
but device-make-and-model and device-info.

The string ("MFG:Canon;MDL:iR 3170C EUR 35.01;DES:Canon iR 3170C EUR 35.01")
that I had seen in the s-c-printer output was probably constructed from the
device-make-and-model and device-info, wasn't it ?

So I guess I should revert the "fix" because we actually don't know the device-id for this printer(s).

Comment 9 Tim Waugh 2010-11-03 11:00:36 UTC
(In reply to comment #8)
> The string ("MFG:Canon;MDL:iR 3170C EUR 35.01;DES:Canon iR 3170C EUR 35.01")
> that I had seen in the s-c-printer output was probably constructed from the
> device-make-and-model and device-info, wasn't it ?

I suppose so. :-(

OK, will revert.

Comment 10 Tim Waugh 2010-11-03 11:06:46 UTC
Oh, it never made it to the upstream bzr branch so this only exists in the foomatic-db SRPM.  Shall I leave that one to you?

Comment 11 Jiri Popelka 2010-11-03 11:12:06 UTC
(In reply to comment #10)
> Shall I leave that one to you?
Yes


Note You need to log in before you can comment on or make changes to this bug.