Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617537 - /etc/init.d/rfcomm: line 23: rfcomm: command not found
/etc/init.d/rfcomm: line 23: rfcomm: command not found
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bluez (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Bastien Nocera
Ken Benoit
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 07:49 EDT by Milos Malik
Modified: 2017-12-06 06:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:13:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2010-07-23 07:49:08 EDT
Description of problem:


Version-Release number of selected component (if applicable):
bluez-compat-4.66-1.el6.x86_64
bluez-libs-4.66-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
# yum -y install bluez-compat
# service rfcomm status
# echo $?
1
# service rfcomm start
Starting rfcomm: /etc/init.d/rfcomm: line 23: rfcomm: command not found
# echo $?
127
  
Actual results:
the service does not start

Expected results:
the service can be started/stopped without errors
Comment 1 RHEL Product and Program Management 2010-07-23 07:57:42 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 2 Bastien Nocera 2010-07-23 08:10:15 EDT
The simple patch.

QE: to reproduce, make sure the bluez package isn't installed, install bluez-compat, check that the bluez package is installed as well, and that "service rfcomm status" doesn't return an error.

Index: bluez.spec
===================================================================
RCS file: /cvs/dist/rpms/bluez/RHEL-6/bluez.spec,v
retrieving revision 1.16
diff -u -p -r1.16 bluez.spec
--- bluez.spec	30 Jun 2010 09:58:59 -0000	1.16
+++ bluez.spec	23 Jul 2010 12:09:01 -0000
@@ -1,7 +1,7 @@
 Summary: Bluetooth utilities
 Name: bluez
 Version: 4.66
-Release: 1%{?dist}
+Release: 2%{?dist}
 License: GPLv2+
 Group: Applications/System
 Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
@@ -106,6 +106,7 @@ Requires: bluez-libs = %{version}
 Summary: Compatibility utilities for Bluetooth devices
 Group: System Environment/Daemons
 Requires: bluez-libs = %{version}
+Requires: bluez = %{version}
 
 %description cups
 This package contains the CUPS backend 
@@ -281,6 +282,10 @@ fi
 %{_mandir}/man1/pand.1.gz
 
 %changelog
+* Fri Jul 23 2010 Bastien Nocera <bnocera@redhat.com> 4.66-2
+- Don't allow installing bluez-compat on its own
+Resolves: rhbz#617537
+
 * Wed Jun 30 2010 Bastien Nocera <bnocera@redhat.com> 4.66-1
 - Update to 4.66
 - Update cable pairing patch
Comment 6 RHEL Product and Program Management 2011-01-07 10:34:33 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Jan Kurik 2017-12-06 06:13:19 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.