Bug 617551 - paplay: volume change and "Invalid memory segment size" error
paplay: volume change and "Invalid memory segment size" error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 08:11 EDT by Tethys
Modified: 2010-11-25 12:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-25 12:10:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2010-07-23 08:11:34 EDT
Description of problem:
paplay gives an error message and changes the volume

Version-Release number of selected component (if applicable):
pulseaudio-0.9.21-6.fc13.x86_64
pulseaudio-utils-0.9.21-6.fc13.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. paplay /usr/share/sounds/purple/send.wav
2.
3.
  
Actual results:
mrburns:~% paplay /usr/share/sounds/purple/send.wav 
Invalid shared memory segment size

The sound does play, but the master volume is set to 10. Sometimes, the volume is set to 0 for Master, PCM, Front, Surround and Side. I can't see any pattern to when it just changes the master volume, and when it changes all of those listed.

Expected results:
paplay should *never* be changing the volume. I just want it to playback what I've asked it to play. If I want the volume changing, I'll do it myself.

Additional info:
Hardware details:
http://www.smolts.org/client/show/pub_56e87ac6-19bb-4390-a9e6-a673dc32532b
Comment 1 Lennart Poettering 2010-11-25 12:00:16 EST
"Invalid shared memory segment size" is an indication that you are running and old PA server against a new PA client, or vice versa.

PA always sets the hw volume to the max of the stream volumes.
Comment 2 Tethys 2010-11-25 12:10:34 EST
Well, I can't see how that could have happened, given it was a fresh
install, with a handful of yum updates. But since I can't reproduce
it any more, I'm going to close this.

Note You need to log in before you can comment on or make changes to this bug.