Bug 617598 - CLI: passing a bad getGroupPluginConfigurationUpdate throws NPE
CLI: passing a bad getGroupPluginConfigurationUpdate throws NPE
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: CLI (Show other bugs)
3.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 10:10 EDT by Sudhir D
Modified: 2010-09-28 09:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-28 09:00:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sudhir D 2010-07-23 10:10:22 EDT
Description of problem:
passing a bad getGroupPluginConfigurationUpdate throws NPE

Version-Release number of selected component (if applicable):
2.4

How reproducible:
Always

Steps to Reproduce:
1. login to CLI as any user
2. ConfigurationManager.getGroupPluginConfigurationUpdate(10004)

  
Actual results:
   1.
      noperm@dhcp6-150.pnq.redhat.com:7080$ ConfigurationManager.getGroupPluginConfigurationUpdate(10004)
   2.
      [Warning] javax.ejb.EJBException: java.lang.NullPointerException
   3.
              at org.jboss.ejb3.tx.Ejb3TxPolicy.handleExceptionInOurTx(Ejb3TxPolicy.java:63)
   4.
              at org.jboss.aspects.tx.TxPolicy.invokeInOurTx(TxPolicy.java:83)
   5.
              at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:191)
   6.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
   7.
              at org.jboss.aspects.tx.TxPropagationInterceptor.invoke(TxPropagationInterceptor.java:95)
   8.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
   9.
              at org.jboss.ejb3.stateless.StatelessInstanceInterceptor.invoke(StatelessInstanceInterceptor.java:62)
  10.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
  11.
              at org.jboss.aspects.security.AuthenticationInterceptor.invoke(AuthenticationInterceptor.java:77)
  12.
              at org.jboss.ejb3.security.Ejb3AuthenticationInterceptor.invoke(Ejb3AuthenticationInterceptor.java:110)
  13.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
  14.
              at org.jboss.ejb3.ENCPropagationInterceptor.invoke(ENCPropagationInterceptor.java:46)
  15.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
  16.
              at org.jboss.ejb3.asynchronous.AsynchronousInterceptor.invoke(AsynchronousInterceptor.java:106)
  17.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
  18.
              at org.jboss.ejb3.stateless.StatelessContainer.localInvoke(StatelessContainer.java:240)
  19.
              at org.jboss.ejb3.stateless.StatelessContainer.localInvoke(StatelessContainer.java:210)
  20.
              at org.jboss.ejb3.stateless.StatelessLocalProxy.invoke(StatelessLocalProxy.java:84)
  21.
              at $Proxy325.getGroupPluginConfigurationUpdate(Unknown Source)
  22.
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  23.
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
  24.
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  25.
              at java.lang.reflect.Method.invoke(Method.java:597)
  26.
              at org.rhq.enterprise.server.remote.RemoteSafeInvocationHandler.invoke(RemoteSafeInvocationHandler.java:109)
  27.
              at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:809)
  28.
              at org.jboss.remoting.transport.servlet.ServletServerInvoker.processRequest(ServletServerInvoker.java:232)
  29.
              at sun.reflect.GeneratedMethodAccessor403.invoke(Unknown Source)
  30.
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  31.
              at java.lang.reflect.Method.invoke(Method.java:597)
  32.
              at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
  33.
              at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
  34.
              at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
  35.
              at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
  36.
              at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
  37.
              at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:288)
  38.
              at $Proxy424.processRequest(Unknown Source)
  39.
              at org.jboss.remoting.transport.servlet.web.ServerInvokerServlet.processRequest(ServerInvokerServlet.java:128)
  40.
              at org.jboss.remoting.transport.servlet.web.ServerInvokerServlet.doPost(ServerInvokerServlet.java:157)
  41.
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
  42.
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
  43.
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
  44.
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
  45.
              at org.rhq.helpers.rtfilter.filter.RtFilter.doFilter(RtFilter.java:124)
  46.
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
  47.
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
  48.
              at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
  49.
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
  50.
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
  51.
              at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
  52.
              at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
  53.
              at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:182)
  54.
              at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
  55.
              at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
  56.
              at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
  57.
              at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
  58.
              at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
  59.
              at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
  60.
              at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
  61.
              at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
  62.
              at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
  63.
              at java.lang.Thread.run(Thread.java:619)
  64.
      Caused by: java.lang.NullPointerException
  65.
              at org.rhq.enterprise.server.configuration.ConfigurationManagerBean.getGroupPluginConfigurationUpdate(ConfigurationManagerBean.java:1969)
  66.
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  67.
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
  68.
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  69.
              at java.lang.reflect.Method.invoke(Method.java:597)
  70.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:112)
  71.
              at org.jboss.ejb3.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:166)
  72.
              at org.rhq.enterprise.server.common.TransactionInterruptInterceptor.addCheckedActionToTransactionManager(TransactionInterruptInterceptor.java:77)
  73.
              at sun.reflect.GeneratedMethodAccessor173.invoke(Unknown Source)
  74.
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  75.
              at java.lang.reflect.Method.invoke(Method.java:597)
  76.
              at org.jboss.ejb3.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:118)
  77.
              at org.rhq.enterprise.server.authz.RequiredPermissionsInterceptor.checkRequiredPermissions(RequiredPermissionsInterceptor.java:156)
  78.
              at sun.reflect.GeneratedMethodAccessor172.invoke(Unknown Source)
  79.
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  80.
              at java.lang.reflect.Method.invoke(Method.java:597)
  81.
              at org.jboss.ejb3.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:118)
  82.
              at org.jboss.ejb3.interceptor.EJB3InterceptorsInterceptor.invoke(EJB3InterceptorsInterceptor.java:63)
  83.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
  84.
              at org.jboss.ejb3.entity.TransactionScopedEntityManagerInterceptor.invoke(TransactionScopedEntityManagerInterceptor.java:54)
  85.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
  86.
              at org.jboss.ejb3.AllowedOperationsInterceptor.invoke(AllowedOperationsInterceptor.java:47)
  87.
              at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
  88.
              at org.jboss.aspects.tx.TxPolicy.invokeInOurTx(TxPolicy.java:79)
  89.
              ... 59 more
  90.
       
  91.
      Wrapped javax.ejb.EJBException: [Warning] java.lang.NullPointerException (<Unknown source>#1)
  92.
      ConfigurationManager.getGroupPluginConfigurationUpdate(10004)
  93.
      ^ 

Expected results:
Should be handled by the code and NPE should not be thrown.

Additional info:
Comment 1 Corey Welton 2010-09-28 09:00:30 EDT
Closing, created a new tracker for overall error-handling improvements in CLI - bug #638181

Note You need to log in before you can comment on or make changes to this bug.