Bug 617605 - Lower case P keys does not work on desktoP
Lower case P keys does not work on desktoP
Status: CLOSED DUPLICATE of bug 595763
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-desktop (Show other bugs)
6.0
All Linux
low Severity urgent
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 10:27 EDT by Bill Burns
Modified: 2010-07-23 11:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 11:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Burns 2010-07-23 10:27:05 EDT
Description of problem:
UPdated to latest nightly on Jul 23 and after reboot
the lowercase P key does not work on any desltoP aPP.
(thus the bizarre looking tyPing)
Terminal, thunderbird, firefox, none of them can receive a
lower case P via the keyboard (they can via cut and Paste).
A remote desktoP to another system get the lowercase P just
fine! So both my laPtoP (t60) and a USB keyboard are
generating it.

No idea if I Picked the correct comPonent, my best guess.
Comment 1 Bill Burns 2010-07-23 10:32:44 EDT
xev show this for tying 'o' 'i' then lowercase P:


KeyPress event, serial 33, synthetic NO, window 0x5c00001,
    root 0x111, subw 0x5c00002, time 4638201, (52,52), root:(56,101),
    state 0x0, keycode 32 (keysym 0x6f, o), same_screen YES,
    XLookupString gives 1 bytes: (6f) "o"
    XmbLookupString gives 1 bytes: (6f) "o"
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x5c00001,
    root 0x111, subw 0x5c00002, time 4638256, (52,52), root:(56,101),
    state 0x0, keycode 32 (keysym 0x6f, o), same_screen YES,
    XLookupString gives 1 bytes: (6f) "o"
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x5c00001,
    root 0x111, subw 0x5c00002, time 4650345, (52,52), root:(56,101),
    state 0x0, keycode 31 (keysym 0x69, i), same_screen YES,
    XLookupString gives 1 bytes: (69) "i"
    XmbLookupString gives 1 bytes: (69) "i"
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x5c00001,
    root 0x111, subw 0x5c00002, time 4650465, (52,52), root:(56,101),
    state 0x0, keycode 31 (keysym 0x69, i), same_screen YES,
    XLookupString gives 1 bytes: (69) "i"
    XFilterEvent returns: False

FocusOut event, serial 33, synthetic NO, window 0x5c00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 33, synthetic NO, window 0x5c00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 33, synthetic NO, window 0x0,
    keys:  17  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
Comment 2 Mark Gordon 2010-07-23 11:05:36 EDT

*** This bug has been marked as a duplicate of bug 595763 ***

Note You need to log in before you can comment on or make changes to this bug.