Bug 61762 - up2date-2.7.60-7.x.2 - usage needs updating
Summary: up2date-2.7.60-7.x.2 - usage needs updating
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python-popt (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On: 62234
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-24 08:46 UTC by James Manning
Modified: 2015-01-07 23:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 17:54:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Manning 2002-03-24 08:46:32 UTC
jmm@bp6:/home/jmm> rpm -q up2date python-popt
up2date-2.7.60-7.x.2
python-popt-0.8.7-7.x.2

[root@bp6 up2date_client]# up2date --usage
Usage: up2date [--configure] [--src] [--nosrc] [--dbpath=<dir>] [--justdb]
        [-k STRING] [--nosig] [--nox] [--showall] [--solvedeps=<deps>]
        [--tmpdir=<directory>] [--version] [--show-channels]
        [--whatprovides=<deps>] [--channel=STRING] [--gpg-flags] [--nodownload] 
[OPTIONS] <packages>

there's a lot of things missing from that --usage that are seen in --help

--download
--list
--help
--usage
--packages
--update

that last one seems like it should definitely be mentioned in usage :)

Comment 1 Alexei Podtelezhnikov 2002-03-24 23:05:31 UTC
--usage was never supposed to have all oprions listed.
Manpages usually do that.

Comment 2 Adrian Likins 2002-03-26 00:15:10 UTC
hmm, looks like some sort of bug in python-popt...

I'll take a look

Comment 3 Adrian Likins 2002-03-27 00:40:44 UTC
looks like python-popt doesnt show an item in --useage if
it has a short option flag. (ie, -h, or -d)

Doh, definately a python-popt bug. I'll
reassign it once it shows up as a component ;->



Comment 4 Mihai Ibanescu 2002-03-27 15:39:35 UTC
Changed back to up2date.

Comment 5 Adrian Likins 2002-03-27 15:45:36 UTC
erk, how did this get to be umb-scheme? I must of done that when
trying to set it to python-popt

Comment 6 James Manning 2002-03-27 15:51:50 UTC
created bug 62106 against bugzilla about the missing component


Comment 7 David Lawrence 2002-03-27 16:01:23 UTC
Changing component to python-popt

Comment 8 Mihai Ibanescu 2002-03-28 16:57:45 UTC
The correct component is python-clap actually, which is missing too :-)

Comment 9 Mihai Ibanescu 2002-03-28 17:39:37 UTC
After further investigation, looks like a popt bug.

Comment 10 James Manning 2002-05-15 19:22:27 UTC
since things seem kosher in 7.3, i'm considering this fixed


Note You need to log in before you can comment on or make changes to this bug.