Bug 617621 - Flashrom / dmidecode bad interaction could brick laptops
Summary: Flashrom / dmidecode bad interaction could brick laptops
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: flashrom
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-23 14:54 UTC by Richard W.M. Jones
Modified: 2010-11-04 23:46 UTC (History)
3 users (show)

Fixed In Version: flashrom-0.9.3-0.1.svn1205.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-04 23:32:21 UTC
Type: ---


Attachments (Terms of Use)

Description Richard W.M. Jones 2010-07-23 14:54:08 UTC
Description of problem:

From upstream bug report:

> DMI string system-manufacturer: "# SMBIOS implementations newer than version 2.6 are not"
> DMI string system-product-name: "# SMBIOS implementations newer than version 2.6 are not"
> DMI string system-version: "# SMBIOS implementations newer than version 2.6 are not"
> DMI string baseboard-manufacturer: "# SMBIOS implementations newer than version 2.6 are not"
> DMI string baseboard-product-name: "# SMBIOS implementations newer than version 2.6 are not"
> DMI string baseboard-version: "# SMBIOS implementations newer than version 2.6 are not"
> DMI string chassis-type: "# SMBIOS implementations newer than version 2.6 are not"
>   

Now this is a serious problem. Apparently dmidecode in Fedora has a
patch in the RPM (dmidecode-warn-on-unsupported-smbios-version.patch)
which breaks the original documented output format. If this only
affected the board enables, it wouldn't be that bad (failing/corrupting
writes on a few dozen boards which can be fixed interactively), but it
also completely disables laptop detection and that means Fedora will get
bug reports about hard lockups and/or disabled fans on laptops.
I don't want to blame Fedora because this is a patch hand-picked from
upstream dmidecode. We'll add a workaorund to flashrom ASAP.

http://www.flashrom.org/pipermail/flashrom/2010-July/004084.html

Version-Release number of selected component (if applicable):

flashrom 0.9.2

How reproducible:

I don't even want to try :-)

Comment 1 Peter Lemenkov 2010-07-26 12:23:12 UTC
Thanks for the report.

Comment 2 Jarod Wilson 2010-07-26 22:37:36 UTC
Anton's taking care of dmidecode these days, not I.

Comment 3 Bug Zapper 2010-07-30 12:47:32 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Fedora Update System 2010-10-26 08:53:42 UTC
flashrom-0.9.3-0.1.svn1205.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/flashrom-0.9.3-0.1.svn1205.fc13

Comment 5 Fedora Update System 2010-10-26 08:53:53 UTC
flashrom-0.9.3-0.1.svn1205.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/flashrom-0.9.3-0.1.svn1205.fc12

Comment 6 Fedora Update System 2010-10-26 08:54:04 UTC
flashrom-0.9.3-0.1.svn1205.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/flashrom-0.9.3-0.1.svn1205.fc14

Comment 7 Fedora Update System 2010-10-27 22:31:32 UTC
flashrom-0.9.3-0.1.svn1205.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update flashrom'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/flashrom-0.9.3-0.1.svn1205.fc13

Comment 8 Fedora Update System 2010-11-04 23:32:11 UTC
flashrom-0.9.3-0.1.svn1205.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-11-04 23:34:03 UTC
flashrom-0.9.3-0.1.svn1205.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-11-04 23:46:37 UTC
flashrom-0.9.3-0.1.svn1205.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.