Bug 617625 - FTBFS in ppp due to change in kernel-headers
Summary: FTBFS in ppp due to change in kernel-headers
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp   
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jiri Skala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-23 15:07 UTC by Paul Howarth
Modified: 2014-11-09 22:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 14:51:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix FTBFS by adding definition of struct pppol2tpv3_addr (842 bytes, application/octet-stream)
2010-07-23 15:07 UTC, Paul Howarth
no flags Details

Description Paul Howarth 2010-07-23 15:07:45 UTC
Created attachment 433979 [details]
Fix FTBFS by adding definition of struct pppol2tpv3_addr

ppp currently fails to build from source in rawhide.

Scratch build of ppp-2.4.5-10.fc14:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2346702

The build failure happens due to a missing pppoe-discovery plugin but that in turn is due to compilation problems that don't themselves cause the build to fail because of poor Makefile construction.

The actual failure is this:
for d in rp-pppoe pppoatm pppol2tp radius; do make -w -C $d all; done
make[2]: Entering directory `/builddir/build/BUILD/ppp-2.4.5/pppd/plugins/rp-pppoe'
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC -Wall -I../../../include '-DRP_VERSION="3.8p"' -I../../.. -c -o plugin.o -fPIC plugin.c
In file included from plugin.c:53:0:
/usr/include/linux/if_pppox.h:75:25: error: field 'pppol2tp' has incomplete type
make[2]: *** [plugin.o] Error 1

It took me a while to track this one down but it's due to ppp bundling a copy of linux/if_pppol2tp.h and this being used in preference to the system one. A recent change in kernel-headers has added a definition of struct pppol2tpv3_addr to this header file, and that definition is needed by linux/if_pppox.h but isn't found when compiling ppp due to the presence of the bundled copy of linux/if_pppol2tp.h. Simplest fix is to add the definition of struct pppol2tpv3_addr to the bundled copy as per the attached patch.

One other query: the ppp-2.4.5-instroot.patch from the F-12 branch that addresses Bug #572174 (missing pppol2tp plugins) isn't present in the F-13 and devel branches - is there a reason for that?

Comment 1 Bug Zapper 2010-07-30 12:47:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Jiri Skala 2010-08-05 14:51:47 UTC
Bug #572174 will be fixed in F-13 +.

Comment 3 Fedora Update System 2010-09-10 06:09:19 UTC
ppp-2.4.5-11.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ppp-2.4.5-11.fc14

Comment 4 Fedora Update System 2010-11-08 22:42:10 UTC
ppp-2.4.5-11.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.