Bug 617635 - Virt-v2v package should not contain Virtio windows drivers
Virt-v2v package should not contain Virtio windows drivers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.0
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
: 624950 (view as bug list)
Depends On: 619349
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 11:33 EDT by Andrew Cathrow
Modified: 2014-09-07 18:53 EDT (History)
7 users (show)

See Also:
Fixed In Version: virt-v2v-0.6.2-3.el6
Doc Type: Bug Fix
Doc Text:
Users upgrading from pre-release versions of Red Hat Enterprise Linux 6 (i.e. the virt-v2v versions less than virt-v2v-0.6.2-2.el6) may be required to update the default virt-v2v configuration file. Specifically, the 'viostor' app for Windows guests is replaced by the 'virtio' app, which now points to the directory containing the complete driver. Refer to the updated default configuration file for further details.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:54:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cathrow 2010-07-23 11:33:03 EDT
The VirtIO windows drivers have been included in the virt-v2v package. These drivers should only be provided by the virtio-win package.

If we need these drivers for virt-v2v then we should ensure that the user installs virtio-win (eg. make dependency) and if required include the appropriate file structure in the virtio-win package - eg. some expanded files in /usr/share/doc/virtio-win-1.0.0/
Comment 2 RHEL Product and Program Management 2010-07-23 11:57:45 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Matthew Booth 2010-08-16 11:51:03 EDT
virtio-win now contains the expanded drivers we need to make this work and upstream contains a patch to incorporate it:

http://www.redhat.com/archives/libguestfs/2010-August/msg00038.html
Comment 5 Matthew Booth 2010-08-17 11:50:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Users upgrading from a RHEL 6 Beta (virt-v2v prior to virt-v2v-0.6.2-2.el6) may be required to update the default virt-v2v configuration file. Specifically, the 'viostor' app for Windows guests is replaced by the 'virtio' app, which now points to the directory containing the complete installable driver. See the updated default configuration file for details.
Comment 6 Matthew Booth 2010-08-17 11:52:03 EDT
Fixed in virt-v2v-0.6.2-2.el6.
Comment 7 Matthew Booth 2010-08-18 09:02:44 EDT
*** Bug 624950 has been marked as a duplicate of this bug. ***
Comment 8 Matthew Booth 2010-08-18 09:04:16 EDT
Fix removed too much. Need to put firstboot, rhsrvany.exe and rhev-apt.exe back.
Comment 9 Matthew Booth 2010-08-18 10:50:46 EDT
Fixed in virt-v2v-0.6.2-3.el6.
Comment 11 Rita Wu 2010-08-18 23:02:28 EDT
Verified on virt-v2v-0.6.2-3.el6.
Now there are not any virtio Windows drivers contained in v2v package.And firstboot, rhsrvany.exe and rhev-apt.exe are moved back to windows dir so we can convert Windows guests successfully.

windows dir after installing v2v: 

# ls /var/lib/virt-v2v/software/windows/
firstboot.bat  rhev-apt.exe  rhsrvany.exe
Comment 13 Ryan Lerch 2010-09-22 03:31:08 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Users upgrading from a RHEL 6 Beta (virt-v2v prior to virt-v2v-0.6.2-2.el6) may be required to update the default virt-v2v configuration file. Specifically, the 'viostor' app for Windows guests is replaced by the 'virtio' app, which now points to the directory containing the complete installable driver. See the updated default configuration file for details.+Users upgrading from pre-release versions of Red Hat Enterprise Linux 6 (i.e. the virt-v2v versions less than virt-v2v-0.6.2-2.el6) may be required to update the default virt-v2v configuration file. Specifically, the 'viostor' app for Windows guests is replaced by the 'virtio' app, which now points to the directory containing the complete driver. Refer to the updated default configuration file for further details.
Comment 14 releng-rhel@redhat.com 2010-11-10 16:54:34 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.