Bug 617642 - Remove deprecate dependencies from orca package
Summary: Remove deprecate dependencies from orca package
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: orca   
(Show other bugs)
Version: 15
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-23 15:46 UTC by Javier Jardón
Modified: 2012-04-17 02:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 02:22:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Javier Jardón 2010-07-23 15:46:51 UTC
Description of problem:

orca doesn't depend on at-spi  and gnome-mag anymore, but in pyatspi (at-spi2) instead
Also, at-spi is deprecated by at-spi2

Version-Release number of selected component (if applicable):
2.31.5



Expected results:

Remove at-spi and gnome-mag dependency

Comment 1 Bug Zapper 2010-07-30 12:47:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Javier Jardón 2011-03-31 21:45:15 UTC
Still valid in F15

Comment 3 Nicola Soranzo 2011-04-06 15:04:50 UTC
The removal of the dependency on deprecated at-spi-python is particularly important because Fedora is trying to remove hal from the distribution, see:

https://fedoraproject.org/wiki/Features/HalRemoval

orca is one of the last packages requiring hal in the Desktop CD:

orca -> at-spi-python -> gnome-python2-bonobo -> libgnome -> gnome-vfs2 -> hal-libs
orca -> gnome-python2-bonobo
orca -> gnome-python2-gnome -> gnome-vfs2

Comment 4 Javier Jardón 2011-04-27 11:08:55 UTC
Still valid in F15 beta

Looking to http://git.gnome.org/browse/orca/tree/configure.in#n42 :

This hard dependencies should be removed:
- gnome-mag
- at-spi-python
- gnome-python2-bonobo
- gnome-python2-gnome
- gnome-speech

So we can remove libgnome, libgnomeui, libbonobo from the default installation

Comment 5 Matthias Clasen 2011-04-27 12:07:11 UTC
grep -l bonobo orca-3.0.1/src/orca/*
orca-3.0.1/src/orca/gnomespeechfactory.py
orca-3.0.1/src/orca/mag.py
orca-3.0.1/src/orca/orca_console_prefs.py
orca-3.0.1/src/orca/orca.py
orca-3.0.1/src/orca/settings.py

In a language as prone to runtime breakage as python, I'm going to wait until it is obvious that the dependencies are really gone.

Comment 6 Matthias Clasen 2011-04-27 12:13:02 UTC
Also:

ORBit.load_typelib('GNOME_Speech')
import GNOME.Speech, GNOME__POA.Speech

in other parts of the code

Comment 7 Joanmarie Diggs 2011-04-27 12:41:01 UTC
(In reply to comment #5)
> grep -l bonobo orca-3.0.1/src/orca/*
> orca-3.0.1/src/orca/gnomespeechfactory.py
> orca-3.0.1/src/orca/mag.py
> orca-3.0.1/src/orca/orca_console_prefs.py
> orca-3.0.1/src/orca/orca.py
> orca-3.0.1/src/orca/settings.py

Problem with grep is that you don't see the surrounding code. 
 
> In a language as prone to runtime breakage as python, I'm going to wait until
> it is obvious that the dependencies are really gone.

Well, let's see. On my Fedora 15 laptop I removed all of the packages being discussed, logged out, logged back in, and Orca continued to work. Mind you, I am still using my built-from-source speech-dispatcher rather than your package. But assuming that's not a problem, what additional obviousity is required? I would be happy to try/test so that we're all sure.

Thanks!

Comment 8 Nicola Soranzo 2011-08-02 13:46:53 UTC
This has been fixed in orca-3.1.4-1.fc16 for next release Fedora 16:

http://koji.fedoraproject.org/koji/buildinfo?buildID=255515

I don't know if it can be backported to F15.

Comment 9 Nicola Soranzo 2011-12-16 10:16:55 UTC
Should this bug be closed as NEXTRELEASE?

http://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow

Comment 10 Kalev Lember 2012-04-17 02:22:30 UTC
Thanks Nicola, closing the bug.


Note You need to log in before you can comment on or make changes to this bug.