Bug 61767 - up2date-2.7.60-7.x.2 - RFE: better explain solvedeps/whatprovides
Summary: up2date-2.7.60-7.x.2 - RFE: better explain solvedeps/whatprovides
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-24 09:55 UTC by James Manning
Modified: 2015-01-07 23:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-24 23:10:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Manning 2002-03-24 09:55:24 UTC
since they're so similar (AFAICT), I think it'd be better if solvedeps occurred 
in the --help output right after whatprovides and had its description change 
to "same as solvedeps, but downloads and installs the packages as well".  I 
like this better than entering an RFE bug against --solvedeps that it doesn't 
mention that the list is comma-separated like whatprovides does :)

[SNIP]
  --solvedeps=<deps>          finds, downloads, and installs the packages
                              needed to solve the list of deps
  --tmpdir=<directory>        where to store temporary files / RPMs
  -u, --update                update system with all relevant packages
  --version                   show program version information
  -v, --verbose               Show additional output
  --show-channels             Show the channel names along with the package
                              name where approriate
  --whatprovides=<deps>       shows the packages which solve the comma
                              separated list of deps
[SNIP]

Comment 1 James Manning 2002-03-24 23:10:00 UTC
i'm gonna make all these beta program only to avoid ppl trying to test and 
confirm with published versions

Comment 2 Alexei Podtelezhnikov 2002-03-24 23:10:10 UTC
Again, use "man up2date", dude!  --help output is _supposed_ to be brief.
Why did you produce so many bugreports without bothering to ask around first?



Note You need to log in before you can comment on or make changes to this bug.