Bug 617674 - SELinux is preventing sedispatch "connectto" access on /var/run/dbus/system_bus_socket.
SELinux is preventing sedispatch "connectto" access on /var/run/dbus/sys...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:891410d35b0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 13:33 EDT by James Laska
Modified: 2013-09-02 02:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 09:16:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2010-07-23 13:33:42 EDT
Summary:

SELinux is preventing sedispatch "connectto" access on
/var/run/dbus/system_bus_socket.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by sedispatch. It is not expected that this
access is required by sedispatch and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:audisp_t:s0
Target Context                system_u:system_r:init_t:s0
Target Objects                /var/run/dbus/system_bus_socket [
                              unix_stream_socket ]
Source                        sedispatch
Source Path                   sedispatch
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.8-3.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.35-0.55.rc6.git0.fc14.x86_64 #1 SMP Thu Jul 22
                              20:03:51 UTC 2010 x86_64 x86_64
Alert Count                   21
First Seen                    Fri 23 Jul 2010 01:32:32 PM EDT
Last Seen                     Fri 23 Jul 2010 01:32:32 PM EDT
Local ID                      1d93cac2-19a6-4040-95bb-2fbe26e0d151
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1279906352.724:6522348): avc:  denied  { connectto } for  pid=1187 comm="sedispatch" path="/var/run/dbus/system_bus_socket" scontext=system_u:system_r:audisp_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=unix_stream_socket



Hash String generated from  catchall,sedispatch,audisp_t,init_t,unix_stream_socket,connectto
audit2allow suggests:

#============= audisp_t ==============
allow audisp_t init_t:unix_stream_socket connectto;
Comment 1 Daniel Walsh 2010-07-26 17:52:27 EDT
This is happening because systemd is not labeling the dbus socket correctly patch is in the works for this.
Comment 2 Lennart Poettering 2010-07-29 09:16:14 EDT
This is now in rawhide. Closing.
Comment 3 Scott Robbins 2010-08-01 18:52:19 EDT
Does that mean one should file a new bug in rawhide--it's still broken.
Comment 4 Scott Robbins 2010-08-01 19:12:35 EDT
Should have said, the bug is still present in rawhide (now F15).  Not sure about F14.
Comment 5 Rahul Sundaram 2010-08-01 21:26:33 EDT
Yes,  if you have problems in Rawhide, please file a new bug report with the details and CC dwalsh AT redhat.com
Comment 6 Scott Robbins 2010-08-01 22:00:43 EDT
Submitted at

https://bugzilla.redhat.com/show_bug.cgi?id=620289

Note You need to log in before you can comment on or make changes to this bug.