Bug 617696 - Should not require postgresql-server
Should not require postgresql-server
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glom (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 14:48 EDT by Adam Williamson
Modified: 2010-07-24 14:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 16:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of Glom requiring postgresql-server (16.85 KB, image/png)
2010-07-23 16:40 EDT, Haïkel Guémar
no flags Details

  None (edit)
Description Adam Williamson 2010-07-23 14:48:43 EDT
Glom has the ability to use a remote postgresql instance, so it really shouldn't have a dependency on postgresql-server.
Comment 1 Murray Cumming 2010-07-23 16:39:23 EDT
Glom defaults to using self-hosting via a postgresql instance that it starts and stops. Glom will even check for its presence at startup, asking the user to complain to the packager.

Why would you want to disable the self-hosting functionality?
Comment 2 Haïkel Guémar 2010-07-23 16:40:02 EDT
Created attachment 434062 [details]
screenshot of Glom requiring postgresql-server

AFAIK, Glom cannot edit databases it (or another instance) didn't create, besides it does require postgresql-server to be installed (or it will complain that installation is incomplete).
To be sure, i asked murrayc and he confirmed that.
Comment 3 Adam Williamson 2010-07-23 17:24:17 EDT
Then it's an upstream bug, but it's still a bug. It seems a perfectly sensible set up that I'd like to store a database on a server machine but create and maintain it using Glom on a different machine. If this isn't an intended use case, why does Glom have the ability to connect to a remote server at all?

If Glom can connect to a remote server, it should not require there to be a local server, both upstream and downstream. If it's only intended to be used with a local server, then the ability to connect to a remote server should be removed.

"Why would you want to disable the self-hosting functionality? "

Dropping the dependency wouldn't disable anything. It would just mean people who don't want to use it aren't forced to have postgresql installed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Murray Cumming 2010-07-23 17:40:19 EDT
(In reply to comment #3)
> Then it's an upstream bug, but it's still a bug. It seems a perfectly sensible
> set up that I'd like to store a database on a server machine but create and
> maintain it using Glom on a different machine. If this isn't an intended use
> case, why does Glom have the ability to connect to a remote server at all?

You can use a remote server. The ability to use a local server does not prevent you from using a remote server.

> If Glom can connect to a remote server, it should not require there to be a
> local server, both upstream and downstream.

It does not require a local server. It requires the ability to start a local server.

> If it's only intended to be used
> with a local server, then the ability to connect to a remote server should be
> removed.
> 
> "Why would you want to disable the self-hosting functionality? "
> 
> Dropping the dependency wouldn't disable anything. It would just mean people
> who don't want to use it aren't forced to have postgresql installed.

So it would make no difference to you, but it would stop people from using the default self-hosting mode without having to think about weird stuff like a database backend installation.

Why do you actually care if postgresql is installed?
Comment 5 Adam Williamson 2010-07-23 19:44:00 EDT
I don't want a server installed on my system unless I actually need it to be there. It takes up space and there's always the possibility it may get enabled by accident.

The appropriate solution to this would be for Glom to use PackageKit to prompt for the installation of postgresql if you actually try to *use* it with a local server. The appropriate solution is not a hard dependency on a package the application does not, in fact, need installed to run.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Murray Cumming 2010-07-24 14:31:26 EDT
(In reply to comment #5)
> The appropriate solution to this would be for Glom to use PackageKit to prompt
> for the installation of postgresql if you actually try to *use* it with a local
> server.

That's not an acceptable user experience for the default way of using Glom. 

> The appropriate solution is not a hard dependency on a package the
> application does not, in fact, need installed to run.

I believe that it is needed for the target users. I do not want the user experience to be broken by the process of packaging and hope that's clear now.

I don't think you'd care if the functionality was (able to be) compiled in like any other code. The use of a separate package makes it easy to break the application, but I don't think that's the job of a packager.

Note You need to log in before you can comment on or make changes to this bug.