Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617803 - Update Request: rubygem-actionpack - additional rack-1.1.0 compat fix
Update Request: rubygem-actionpack - additional rack-1.1.0 compat fix
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-actionpack (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Mo Morsi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 00:20 EDT by Mo Morsi
Modified: 2010-09-17 14:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-actionpack-2.3.5-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-17 14:20:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mo Morsi 2010-07-24 00:20:50 EDT
Description of problem:
Since rack-1.1.0 stores headers in an array and not a string, rubygem-actionpack requires the following patch:

http://cvs.fedoraproject.org/viewvc/rpms/rubygem-actionpack/F-13/rubygem-actionpack-2.3.5-rack-compat.patch?view=markup

Attached is an updated patch with one addition, removing a newline from being prepended when multiple headers are present. 

This newline made sense in the context of the headers string as it acted as a delimiter. 

But in the context of the headers array it does not, and infact it causes breakage in actionpack/action_controller/integration.rb line 334 which will throw the following exception if the first character in the header string is a newline (as it is if there are multiple headers)

You have a nil object when you didn't expect it!
You might have expected an instance of ActiveRecord::Base.
The error occurred while evaluating nil.[] (NoMethodError)

The patch with the removal of the newline can be found here

http://mo.morsi.org/files/patches/rubygem-actionpack-2.3.5-rack-compat.patch

Version-Release number of selected component (if applicable):
rubygem-actionpatch-2.3.5

How reproducible:
Occurs when running the deltacloud feature suite against rubygems installed via yum.

Steps to Reproduce:
1. Check out deltacloud as described here http://deltacloud.org/contribute.html
2. cd aggregator/src
3. rake feature
  
Actual results:
Exceptions thrown concerning nil class

Expected results:
Feature suite successfully executes (as it does when my patch is applied against actionpack 2.3.5)
Comment 1 Fedora Admin XMLRPC Client 2010-08-17 19:05:36 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Update System 2010-09-15 23:01:19 EDT
rubygem-actionpack-2.3.5-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/rubygem-actionpack-2.3.5-3.fc13
Comment 3 Fedora Update System 2010-09-17 14:20:06 EDT
rubygem-actionpack-2.3.5-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.