Bug 61781 - Visiting this URL causes crashes
Visiting this URL causes crashes
Product: Red Hat Public Beta
Classification: Retired
Component: galeon (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Blizzard
Depends On:
  Show dependency treegraph
Reported: 2002-03-24 10:32 EST by Fortepianissimo
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-12 13:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
HTML source of the crashing site (24.58 KB, text/html)
2002-04-11 19:08 EDT, Fortepianissimo
no flags Details

  None (edit)
Description Fortepianissimo 2002-03-24 10:32:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020321

Description of problem:
Visiting the site https://esprit.as.cmu.edu/sio/ crashes Galeon.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Fire up Galeon and visit https://esprit.as.cmu.edu/sio/
2. Bang.

Actual Results:  Crash and burn.

Expected Results:  Should be fine.

Additional info:

Several observations:

1. If I wipe out ~/.galeon and ~/.gconf* , uninstall GConf* and galeon rpms and
reinstall them, on the first run under English locale, it works just fine - the
password dialog would pop up waiting for my input.

2. However the subsequent 1st crash on the site will cause crashes on all future
visit to the same site.

3. Changing locale to Traditional Chinese (BIG5) would cause the "1st" crash
immediately (export LANG=zh_TW.Big5), and hence all the future visits cause crashes.

4. Even posting bug reports in Bugzilla caused crashes! (something to do with SSL?)

5. Using Mozilla 0.9.9 to visit all the sites mentioned above are fine. (so it's
a Galeon or GConf specific issue?)
Comment 1 Warren Togami 2002-04-08 05:16:10 EDT
I tried visiting that URL in Konqueror and Galeon.  Both require an HTTP login 
name and password.  I click cancel in both browsers and it says "Unauthorized 
Proper authorization is required for this area. Either your browser does not 
perform authorization, or your authorization has failed."
Comment 2 Fortepianissimo 2002-04-08 11:42:15 EDT
Yes the link metioned requires password authorization - but galeon crashed
before even presenting a password input dialog box. Mozilla worked fine - I was
able to enter the password and visited the site. I'm sure the password Galeon
stored from my last (non-crashing) visit is correct.
Comment 3 Warren Togami 2002-04-08 15:24:35 EDT
I am unable to trigger this crashing bug in Galeon, I'm guessing because I 
can't get into the site.

Can you save the HTML inside that password protected area and post it elsewhere 
for testing purpose?  (That will at least rule out non-auth related bugs.)
Comment 4 Fortepianissimo 2002-04-11 19:08:41 EDT
Created attachment 53524 [details]
HTML source of the crashing site
Comment 5 Fortepianissimo 2002-04-11 19:13:44 EDT
Maybe this is useful - the debugging info displayed in Bug Buddy:

no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024
(LWP 32577)]
[New Thread 2049 (LWP 32646)]
[New Thread 1026 (LWP 32647)]
[New Thread 2051 (LWP 32648)]
[New Thread 3076 (LWP 32649)]
[New Thread 8197 (LWP 32720)]

0x420b47f9 in wait4 () from /lib/i686/libc.so.6
#0  0x420b47f9 in wait4 () from /lib/i686/libc.so.6
#1  0x4213030c in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x407a4ca3 in waitpid () from /lib/i686/libpthread.so.0
#3  0x40283ff8 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#4  0x407a2f75 in pthread_sighandler () from /lib/i686/libpthread.so.0
#5  <signal handler called>
#6  0x40014d43 in is_sound_device () from /usr/lib/libartsdsp.so.0
#7  0x40015832 in fopen () from /usr/lib/libartsdsp.so.0
#8  0x4066372e in gdk_pixmap_colormap_create_from_xpm ()
   from /usr/lib/libgdk-1.2.so.0
#9  0x401faa0c in pixmap_new () from /usr/lib/libglade.so.0
#10 0x401f450c in glade_xml_build_widget () from /usr/lib/libglade.so.0
#11 0x401f57e6 in table_build_children () from /usr/lib/libglade.so.0
#12 0x401f4c95 in glade_xml_set_common_params () from /usr/lib/libglade.so.0
#13 0x401f4523 in glade_xml_build_widget () from /usr/lib/libglade.so.0
#14 0x401df7e4 in gnomedialog_build_children ()
   from /usr/lib/libglade-gnome.so.0
#15 0x401f4c95 in glade_xml_set_common_params () from /usr/lib/libglade.so.0
#16 0x401f4523 in glade_xml_build_widget () from /usr/lib/libglade.so.0
#17 0x401f427c in glade_xml_build_interface () from /usr/lib/libglade.so.0
#18 0x401f2e0a in glade_xml_construct () from /usr/lib/libglade.so.0
#19 0x401f2c43 in glade_xml_new () from /usr/lib/libglade.so.0
#20 0x08091b8b in glade_widget_new ()
#21 0x080e387d in CPromptService::PromptUsernameAndPassword ()
#22 0x40b134ba in nsPrompt::PromptUsernameAndPassword ()
   from /usr/lib/mozilla/components/libembedcomponents.so
#23 0x4250baac in si_CheckGetUsernamePassword ()
   from /usr/lib/mozilla/components/libwallet.so
#24 0x42510711 in SINGSIGN_PromptUsernameAndPassword ()
   from /usr/lib/mozilla/components/libwallet.so
#25 0x424fd08f in nsSingleSignOnPrompt::PromptUsernameAndPassword ()
   from /usr/lib/mozilla/components/libwallet.so
#26 0x40bff8c1 in nsHttpChannel::PromptForUserPass ()
   from /usr/lib/mozilla/components/libnecko.so
#27 0x40bfe84c in nsHttpChannel::GetCredentials ()
   from /usr/lib/mozilla/components/libnecko.so
#28 0x40bfe0f0 in nsHttpChannel::ProcessAuthentication ()
   from /usr/lib/mozilla/components/libnecko.so
#29 0x40bfc01a in nsHttpChannel::ProcessResponse ()
   from /usr/lib/mozilla/components/libnecko.so
#30 0x40c01ed1 in nsHttpChannel::OnStartRequest ()
   from /usr/lib/mozilla/components/libnecko.so
#31 0x40bb5913 in nsOnStartRequestEvent::HandleEvent ()
   from /usr/lib/mozilla/components/libnecko.so
#32 0x40bb5257 in nsARequestObserverEvent::HandlePLEvent ()
   from /usr/lib/mozilla/components/libnecko.so
#33 0x40104332 in PL_HandleEvent () from /usr/lib/libxpcom.so
#34 0x40104239 in PL_ProcessPendingEvents () from /usr/lib/libxpcom.so
#35 0x401053fb in nsEventQueueImpl::ProcessPendingEvents ()
   from /usr/lib/libxpcom.so
#36 0x4164b4b6 in event_processor_callback ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#37 0x4164b1e4 in our_gdk_io_invoke ()
#38 0x4068e07e in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#39 0x4068f2b3 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#40 0x4068f8f9 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#41 0x406903ac in g_main_run () from /usr/lib/libglib-1.2.so.0
#42 0x4059c183 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#43 0x0809741c in main ()
#44 0x42017499 in __libc_start_main () from /lib/i686/libc.so.6
#0  0x420b47f9 in wait4 () from /lib/i686/libc.so.6
No symbol table info available.
#1  0x4213030c in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x407a4ca3 in waitpid () from /lib/i686/libpthread.so.0
No symbol table info available.
#3  0x40283ff8 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
No symbol table info available.
#4  0x407a2f75 in pthread_sighandler () from /lib/i686/libpthread.so.0
No symbol table info available.
#5  <signal handler called>
No symbol table info available.
#6  0x40014d43 in is_sound_device () from /usr/lib/libartsdsp.so.0
No symbol table info available.
#7  0x40015832 in fopen () from /usr/lib/libartsdsp.so.0
No symbol table info available.
Comment 6 Fortepianissimo 2002-04-11 19:14:56 EDT
Here are the ssl packages installed on my system:

Comment 7 Fortepianissimo 2002-04-12 13:01:56 EDT
Alright I've also reported to bugzilla.gnome.org


And the bug was already tagged as duplicate to


And the conclusion so far seems to be the use of artsdsp in running Galeon.
Indeed when I tried to run Galeon WITHOUT artsdsp prefix everything is fine. The
crashes only occur when artsdsp is used.
Comment 8 Fortepianissimo 2002-04-12 13:02:56 EDT
I forgot to mention: both arts from KDE2 and KDE3 cause the same crashes. (I'm
now running KDE3)
Comment 9 Christopher Blizzard 2002-08-29 17:51:04 EDT

Note You need to log in before you can comment on or make changes to this bug.