Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617810 - huge_page_setup_helper.py with empty answers
huge_page_setup_helper.py with empty answers
Status: CLOSED DUPLICATE of bug 630171
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libhugetlbfs (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Anton Arapov
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 01:37 EDT by Qian Cai
Modified: 2014-06-18 04:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-07 05:15:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Cai 2010-07-24 01:37:26 EDT
Description of problem:
Both regards hit the straight ENTER to the answers. Might we could repeat the answer for those.

What group should have access to the huge pages? (The group will be created, if need be):  <ENTER>
Traceback (most recent call last):
  File "/usr/bin/huge_page_setup_helper.py", line 139, in <module>
    if userGroupReq[0].isdigit() or userGroupReq[0] == "-":
IndexError: string index out of range

What user(s) should have access to the huge pages (space-delimited list, users created as needed)? <ENTER>

Saved original /etc/sysctl.conf as /etc/sysctl.conf.backup
Saved original /etc/security/limits.d/hugepages.conf as /etc/security/limits.d/hugepages.conf.backup

Final configuration:
 * Total System Memory......:    879 MB
 * Shared Mem Max Mapping...:    200 MB
 * System Huge Page Size....:      2 MB
 * Available Huge Pages.....:    100
 * Total size of Huge Pages.:    200 MB
 * Remaining System Memory..:    679 MB
 * Huge Page User Group.....:  huge (502)

In fact, /etc/security/limits.d/hugepages.conf did not change,
# cat /etc/security/limits.d/hugepages.conf
root		soft	memlock		2048
root		hard	memlock		2048
caiqian		soft	memlock		2048
caiqian		hard	memlock		2048

Version-Release number of selected component (if applicable):
libhugetlbfs-2.8-2.el6
Comment 1 Anton Arapov 2010-10-20 07:19:49 EDT
thanks for the valuable comment. Patch went upstream, will appear in Fedora after, and so forth... :)
Comment 2 Anton Arapov 2010-12-07 05:15:02 EST
closed of 630171 rebase.

*** This bug has been marked as a duplicate of bug 630171 ***

Note You need to log in before you can comment on or make changes to this bug.