Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617812 - [abrt] crash in nicotine+-1.2.15-2.fc13: uglytree.py:149:GetParent:TypeError: list indices must be integers, not tuple
[abrt] crash in nicotine+-1.2.15-2.fc13: uglytree.py:149:GetParent:TypeError:...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nicotine+ (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
abrt_hash:bc8c2f22
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 02:37 EDT by Dario Castellarin
Modified: 2010-12-27 20:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-27 20:20:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.23 KB, text/plain)
2010-07-24 02:38 EDT, Dario Castellarin
no flags Details

  None (edit)
Description Dario Castellarin 2010-07-24 02:37:59 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/nicotine.py
comment: This happens every time I try a recursive upload to someone.
component: nicotine+
executable: /usr/bin/nicotine.py
kernel: 2.6.34.1-29.fc13.x86_64
package: nicotine+-1.2.15-2.fc13
reason: uglytree.py:149:GetParent:TypeError: list indices must be integers, not tuple
release: Fedora release 13 (Goddard)

backtrace
-----
uglytree.py:149:GetParent:TypeError: list indices must be integers, not tuple

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/userbrowse.py", line 660, in OnUploadDirectoryRecursiveTo
    self.OnUploadDirectoryTo(widget, recurse=1)
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/userbrowse.py", line 696, in OnUploadDirectoryTo
    self.UploadDirectoryTo(user, dir, recurse)
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/userbrowse.py", line 678, in UploadDirectoryTo
    self.UploadDirectoryTo(user, self.DirStore.on_get_path(node), recurse)
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/uglytree.py", line 199, in on_get_path
    path = (self.GetOffset(node),)
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/uglytree.py", line 177, in GetOffset
    p_level, p_number = self.GetChild(self.GetParent(node))
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/uglytree.py", line 149, in GetParent
    return (level-1, self.tree1[level][number][1])
TypeError: list indices must be integers, not tuple

Local variables in innermost frame:
node: (2, (6, 2))
self: <UglyTree object at 0x7f328c183dc0 (PyGtkGenericTreeModel at 0x7051340)>
number: (6, 2)
level: 2

How to reproduce
-----
1. connect
2. start a recursive upload to someone
3.
Comment 1 Dario Castellarin 2010-07-24 02:38:02 EDT
Created attachment 434109 [details]
File: backtrace
Comment 2 Mohamed El Morabity 2010-11-22 04:31:22 EST
Thanks for this report. Please test the latest version of nicotine+ available in
the stable repos:
   # yum update nicotine+
Comment 3 Mohamed El Morabity 2010-12-27 20:10:07 EST
No news is good news. Closing since there is no answer and a newer version is available.

Note You need to log in before you can comment on or make changes to this bug.