Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 617823 - Serial port don't attach corretly with libvirt 0.8.2
Serial port don't attach corretly with libvirt 0.8.2
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 05:11 EDT by jrodriguez
Modified: 2016-03-20 20:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-20 20:17:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jrodriguez 2010-07-24 05:11:07 EDT
When i try create a vm with a serial port in libvirt 0.8.2, the vm don't recognize the serial port, but when i try the same xml with libvirt 0.7.5, the vm recognize correctly the serial port.

the XML is this:
<?xml version="1.0" encoding="UTF-8"?>
<domain type="kvm">
  <name>uml2</name>
  <memory>1048576</memory>
  <vcpu>1</vcpu>
  <os>
    <type arch="i686">hvm</type>
    <boot dev="hd"/>
    <boot dev="cdrom"/>
  </os>
  <features>
    <pae/>
    <acpi/>
    <apic/>
  </features>
  <clock sync="localtime"/>
  <devices>
    <emulator>/usr/bin/kvm</emulator>
    <disk type="file" device="disk">
      <source file="/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/fs/root_cow_fs"/>
      <target dev="hda"/>
    </disk>
    <disk type="file" device="cdrom">
      <source file="/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/fs/opt_fs.iso"/>
      <target dev="hdb"/>
    </disk>
    <interface type="bridge" name="eth1" onboot="yes">
      <source bridge="Net0"/>
      <mac address="fe:fd:00:00:01:01"/>
    </interface>
    <graphics type="vnc" listen=""/>
    <serial type="unix">
      <source mode="bind" path="/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/uml2_socket"/>
      <target port="1"/>
    </serial>
  </devices>
</domain>


kvm line with libvirt 0.8.2
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin QEMU_AUDIO_DRV=none /usr/bin/kvm -S -M pc-0.12 -cpu qemu32 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name uml2 -uuid f1ab8adf-cfe7-1752-0d53-af397ffcf2cd -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/uml2.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=utc -boot cd -drive file=/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/fs/root_cow_fs,if=none,id=drive-ide0-0-0,boot=on -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/fs/opt_fs.iso,if=none,media=cdrom,id=drive-ide0-0-1,readonly=on -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -device rtl8139,vlan=0,id=net0,mac=fe:fd:00:00:01:01,bus=pci.0,addr=0x4 -net tap,fd=17,vlan=0,name=hostnet0 -chardev socket,id=serial0,path=/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/uml2_socket,server,nowait -device isa-serial,chardev=serial0 -usb -vnc :0 -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 

kvm line with libvirt 0.7.5
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin QEMU_AUDIO_DRV=none /usr/bin/kvm -S -M pc-0.12 -cpu qemu32 -enable-kvm -m 1024 -smp 1 -name uml2 -uuid fc7f24b0-3745-0fc4-632e-ce639c7fe3e9 -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/uml2.monitor,server,nowait -monitor chardev:monitor -boot cd -drive file=/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/fs/root_cow_fs,if=ide,index=0,boot=on -drive file=/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/fs/opt_fs.iso,if=ide,media=cdrom,index=1 -net nic,macaddr=fe:fd:00:00:01:01,vlan=0,name=nic.0 -net tap,fd=17,vlan=0,name=tap.0 -chardev socket,id=serial0,path=/root/.vnx/simulations/tutorial-r1_xp/vms/uml2/uml2_socket,server,nowait -serial chardev:serial0 -parallel none -usb -vnc :0 -vga cirrus
Comment 1 Cole Robinson 2016-03-20 20:17:25 EDT
Sorry this bug never received a response. Libvirt has changed very much since this bug was filed, and I haven't heard any recent reports of unix socket chardevs not working, so I assume this is fixed. If you can still reproduce with recent libvirt and qemu, please reopen

Note You need to log in before you can comment on or make changes to this bug.