Bug 61783 - SRPMS rebuilt failed (segfault)
SRPMS rebuilt failed (segfault)
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: libtool (Show other bugs)
skipjack-beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-24 10:45 EST by Fortepianissimo
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 12:03:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config.log (5.85 KB, text/plain)
2002-03-25 10:54 EST, Fortepianissimo
no flags Details
build log (10.07 KB, text/plain)
2002-03-25 10:55 EST, Fortepianissimo
no flags Details

  None (edit)
Description Fortepianissimo 2002-03-24 10:45:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020321

Description of problem:
Rebuilding libtabe-0.2.4a-8.src.rpm caused the following errors (this is to
build for i686 - but the same happened for "--target i386"):

if [ ! -x tsipackdb ]; then chmod 755 tsipackdb; fi
make[1]: Leaving directory `/data2/usr.src/redhat/BUILD/libtabe/util'
(cd tsi-src; make)
/data2/usr.src/redhat/BUILD/libtabe/tsi-src
make[1]: Entering directory `/data2/usr.src/redhat/BUILD/libtabe/tsi-src'
../libtool --mode=execute ../util/tsiadd -d tsi.db -f tsi.src -r -y
There're 138133 queries, 138133 added.
rm -rf yin.db
../libtool --mode=execute ../util/tsiyindump -d tsi.db -y yin.db
make[1]: *** [yin.db] Segmentation fault
make[1]: Leaving directory `/data2/usr.src/redhat/BUILD/libtabe/tsi-src'
make: *** [data] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.70212 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.70212 (%build)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuild libtabe-0.2.4a-8.src.rpm
2. compilation stopped and error messages given in "Description" were shown.
	

Actual Results:  Compilation errors.

Expected Results:  A shinny new RPM!

Additional info:
Comment 1 Leon Ho 2002-03-24 19:38:41 EST
Look like it is a libtool seg fault - Changing the component.

I have also tried several build systems and seem it does not reproduce this error for me.
What is your spec of your system? Have you changed its clock speed etc?


Comment 2 Jens Petersen 2002-03-25 10:46:39 EST
I can't reproduce either. Is this from a fresh skipjack-beta1 install?
Could you post the full build log?
Comment 3 Fortepianissimo 2002-03-25 10:54:05 EST
Created attachment 50164 [details]
config.log
Comment 4 Fortepianissimo 2002-03-25 10:55:30 EST
Created attachment 50165 [details]
build log
Comment 5 Fortepianissimo 2002-03-25 11:01:06 EST
Above are two logs generated by executing

rpm --rebuild libtabe-0.2.4a-8.src.rpm

My /etc/rpmrc:

buildarchtranslate:i686: i686
optflags: i686 -O6 -march=i686

Other related rpm packages installed:

automake-1.4p5-4
autoconf-2.13-16
automake15-1.5-1
autoconf253-2.53-1
libtool-1.4.2-6
libtool-libs13-1.3.5-2
libtool-libs-1.4.2-6
gcc3-3.0.4-1
libgcc-3.0.4-1
gcc3-c++-3.0.4-1
gcc-c++-2.96-107
gcc-2.96-107

db2-devel-2.4.14-9
db3-devel-3.2.9-5
db2-2.4.14-9
db3-3.2.9-5
db31-3.1.17-1
db3-utils-3.2.9-5
db1-1.85-7
db1-devel-1.85-7

The system is manually upgraded from 7.2 (by applying new rpms).
Comment 6 Fortepianissimo 2002-03-25 12:02:54 EST
After reinstalling db3* i386 rpm everything is back to normal - the compilation
went perfectly!

To make sure it's not caused by gcc optimization bug, I recomplied again db3
packages using -O6 -march=i686 and everything worked fine.

Conclusion: something screwed up when I built the optimized versions of db3
(maybe it's the older gcc, libtool or whatever). But now everything is fine.
Comment 7 Michael Fulbright 2002-03-25 17:10:27 EST
OK, then it's not our problem. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.