Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 617865 - [abrt] crash in gcompris-9.3-1.fc13: magazine_chain_pop_head: Process /usr/bin/gcompris was killed by signal 11 (SIGSEGV)
[abrt] crash in gcompris-9.3-1.fc13: magazine_chain_pop_head: Process /usr/bi...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gcompris (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:d749aa4982e18f749d9aa9651a4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 10:56 EDT by Libor Ballaty
Modified: 2011-01-01 10:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-01 10:01:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (73.93 KB, text/plain)
2010-07-24 10:56 EDT, Libor Ballaty
no flags Details

  None (edit)
Description Libor Ballaty 2010-07-24 10:56:49 EDT
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gcompris
comment: Started when I tried to start the game. it didn't crash at that point the second time I started it.
component: gcompris
crash_function: magazine_chain_pop_head
executable: /usr/bin/gcompris
global_uuid: d749aa4982e18f749d9aa9651a415608b0462795
kernel: 2.6.33.3-85.fc13.x86_64
package: gcompris-9.3-1.fc13
rating: 4
reason: Process /usr/bin/gcompris was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.Start Gcompris
2.Click on top left icon
3.Click on keyboard icon
Comment 1 Libor Ballaty 2010-07-24 10:56:52 EDT
Created attachment 434151 [details]
File: backtrace
Comment 2 Fedora Admin XMLRPC Client 2010-12-30 13:59:03 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Hans de Goede 2011-01-01 10:01:36 EST
Hi,

I'm the new maintainer of gcompris and going through all open gcompris bugs. gcompris-0.9.3 suffered from some memory corruption problems. And this bug seems to be one of a number of abrt reported bugs caused by these memory corruption problems. Unfortunately bugs like these are very hard to fix and I don't have the time to track this down.

Upstream has recently released gcompris-0.9.5, which contains some memory corruption fixes which hopefully fixes this.

This is available as an update for all supported Fedora releases (F-13 and F-14). To get this update do:
yum update --enablerepo=updates-testing gcompris

If you still encounter problems with 0.9.5 please file a new bug with a 0.9.5 generated backtrace attached (through abrt).

If this update fixes your problems please login and then give it positive karma here:
https://admin.fedoraproject.org/updates/gcompris-9.5-1.fc13
https://admin.fedoraproject.org/updates/gcompris-9.5-1.fc14

Thanks & Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.