Bug 617867 - Brightness control with intel gma 945 does not work
Brightness control with intel gma 945 does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Garrett
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 10:59 EDT by Fabian Deutsch
Modified: 2011-11-07 04:45 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-07 04:45:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 568611 None None None Never

  None (edit)
Description Fabian Deutsch 2010-07-24 10:59:18 EDT
I've got a MacBook with an Intel GMA 945, currently on F13 the birghtness control does not work. This problem might be the same as in 
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/568611/
Comment 1 Bug Zapper 2010-07-30 08:49:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Kevin Fenzi 2010-08-08 17:30:36 EDT
Moving over to xorg-x11-drv-intel for further debugging.
Comment 3 Jens Knutson 2010-08-24 22:21:45 EDT
I experience a similar problem on my Dell Studio 1558, which uses the built-in Arrandale GPU.

my smolt: http://www.smolts.org/client/show/pub_e95155fc-9a15-4da4-bbc2-4ca17c7dac50
(kernel listed is outdated though, I'm using the latest as of today.)
Comment 4 Adam Williamson 2010-10-06 18:13:59 EDT
Jens, please report your bug separately, it is unlikely to have the same cause as Fabian's bug.

Reporter, do you still see this bug with current F13 (or F14 if you're now using that)? Can you post the contents of /sys/class/backlight ?
Comment 5 Fabian Deutsch 2010-10-07 04:42:28 EDT
Yes, I am still having this issue on Fedora Rawhide. (not all the latest updates, as there is this glibc breakage)

There are no contents:
[fabiand@proprietary ~]$ ls /sys/class/backlight/
[fabiand@proprietary ~]$ 

[fabiand@proprietary ~]$ uname -a
Linux proprietary.local 2.6.36-0.32.rc6.git2.fc15.i686 #1 SMP Sun Oct 3 20:37:15 UTC 2010 i686 i686 i386 GNU/Linux
[fabiand@proprietary ~]$ 


[fabiand@proprietary ~]$ rpm -qa "(kernel|gnome-power)*"
gnome-power-manager-2.31.91-1.fc14.i686
kernel-devel-2.6.36-0.28.rc6.git0.fc15.i686
kernel-2.6.36-0.28.rc6.git0.fc15.i686
kernel-2.6.36-0.30.rc6.git0.fc15.i686
kernel-devel-2.6.36-0.30.rc6.git0.fc15.i686
kernel-devel-2.6.36-0.32.rc6.git2.fc15.i686
kernel-headers-2.6.36-0.32.rc6.git2.fc15.i686
kernel-2.6.36-0.32.rc6.git2.fc15.i686
Comment 6 Fabian Deutsch 2010-10-07 04:45:52 EDT
[fabiand@proprietary ~]$ dmesg | grep applesmc
[   22.070057] applesmc: Apple MacBook (v2) detected:
[   22.070064] applesmc:  - Model with accelerometer
[   22.070067] applesmc:  - Model without light sensors and backlight
[   22.070071] applesmc:  - Model with 10 temperature sensors
[   22.125726] applesmc: device successfully initialized (0xe0, 0x00).
[   22.125732] applesmc: device successfully initialized.
[   22.126623] applesmc: 1 fans found.
[   22.132446] input: applesmc as /devices/platform/applesmc.768/input/input11
[   22.136123] applesmc: driver successfully loaded.

But I am quite sure that it has a backlight ;) and a light sensor.
Comment 7 Adam Williamson 2010-10-07 11:42:04 EDT
AIUI, this is more of a kernel issue than a graphics driver issue. mjg59 wrote a blog post about this stuff - http://mjg59.livejournal.com/127103.html - which obviously means he's the expert, so enjoy, Matt =)
Comment 8 Marius Andreiana 2010-11-12 14:49:39 EST
dupe of #539961 ?
Comment 9 Steevithak 2011-01-30 00:04:10 EST
also might be a dupe of bug 641978
Comment 10 Fabian Deutsch 2011-11-07 04:45:20 EST
Fixed for me (for some months).

Note You need to log in before you can comment on or make changes to this bug.