Bug 617886 - Wine 1.2 complains about missing wineserver
Wine 1.2 complains about missing wineserver
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 12:58 EDT by Chris Rankin
Modified: 2014-10-06 17:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 15:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Rankin 2010-07-24 12:58:56 EDT
Description of problem:
Running anything with Wine 1.2 results in message "could not exec wineserver".

Version-Release number of selected component (if applicable):
1.2

How reproducible:
Always

Steps to Reproduce:
1. Install wine 1.2 packages wine-core-1.2.0-1, wine-common-1.2.0-1, wine-desktop-1.2.0-1 and a few others.
2. Run winecfg
  
Actual results:
wine: could not exec wineserver

Expected results:
The winecfg app to run.

Additional info:
wineserver does not seem to have been included in any of the updated wine packages, although the rest of the wine packages seem to expect it.

As bugs go, this one earns someone a brown paper bag.
Comment 1 T-Gergely 2010-07-25 10:06:33 EDT
Same goes for Fedora 12. Duh. Had to install wine-wow-1.2.0-1.fc12.i686. The wine package depends on wine-wow, but the dependency chain is not that good, as when I remove wine-pulseaudio, that removes wine, too.
Comment 2 Andreas Bierfert 2010-08-05 15:39:17 EDT
Well either you have to install the wine meta package which resolves all dependencies as needed or you have to figure out how the mechanics of the wine packages work. wine-wow cannot be included as a dependencies of wine-core because of wow64. Actually it has been _split_ from wine-core to allow for 32bit support on 64bit system.
Comment 3 Chris Rankin 2010-08-05 16:01:49 EDT
Fine. Then can you maybe update the package description for wine-wow-1.2.0-1.fc13 to something slightly less fatuous than:

"Files for wine wow seperation"

instead, please? Possibly so that it actually describes what that package contains and what it it for?
Comment 4 Andrew Travneff 2010-08-22 08:23:29 EDT
Agree with Chris proposition. Wine-wow can be found with "yum provides */wineserver", but such description gives very small info to you.
Comment 5 q2dg 2014-10-06 17:26:47 EDT
Such description still remains in Fedora 20...

Note You need to log in before you can comment on or make changes to this bug.