Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617968 - [abrt] wine-core-1.2.0-1.fc14: Process /usr/bin/wine-preloader was killed by signal 11 (SIGSEGV)
[abrt] wine-core-1.2.0-1.fc14: Process /usr/bin/wine-preloader was killed by ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
abrt_hash:9f6b612b1ff4c8270091cb5d5fb...
:
: 618931 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-25 06:23 EDT by Ola Thoresen
Modified: 2010-08-19 22:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: wine-1.2.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 21:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.16 KB, text/plain)
2010-07-25 06:23 EDT, Ola Thoresen
no flags Details
fix for the segfault (557 bytes, patch)
2010-07-28 12:36 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Ola Thoresen 2010-07-25 06:23:36 EDT
abrt version: 1.1.5
architecture: i686
cmdline: /usr/bin/wine winecfg.exe '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
component: wine
executable: /usr/bin/wine-preloader
global_uuid: 9f6b612b1ff4c8270091cb5d5fb83847a553ffa1
kernel: 2.6.35-0.36.rc4.git5.fc14.i686
package: wine-core-1.2.0-1.fc14
rating: 0
reason: Process /usr/bin/wine-preloader was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Rawhide)
How to reproduce: Starting any program under wine.
time: 1280053322
uid: 4616

backtrace
-----
warning: core file may not match specified executable file.
[New Thread 10495]
Failed to read a valid object file image from memory.
Core was generated by `/usr/bin/wine winecfg.exe                        '.
Program terminated with signal 11, Segmentation fault.
#0  0x68003275 in ?? ()

Thread 1 (Thread 10495):
#0  0x68003275 in ?? ()
No symbol table info available.
#1  0x00000000 in ?? ()
No symbol table info available.
No shared libraries loaded at this time.
No symbol table is loaded.  Use the "file" command.
No symbol table is loaded.  Use the "file" command.
eax            0x0	0
ecx            0xbfbc8774	-1078163596
edx            0xb77216c0	-1217259840
ebx            0x68020fbc	1744965564
esp            0xbfbc8798	0xbfbc8798
ebp            0xbfbc88b4	0xbfbc88b4
esi            0x68021900	1744967936
edi            0x6802151c	1744966940
eip            0x68003275	0x68003275
eflags         0x10246	[ PF ZF IF RF ]
cs             0x73	115
ss             0x7b	123
ds             0x7b	123
es             0x7b	123
fs             0x33	51
gs             0x3b	59
No function contains program counter for selected frame.
Debuginfo absent: 1399016934c8e4eca0bf271f50e64db98ab1c234
Comment 1 Ola Thoresen 2010-07-25 06:23:38 EDT
Created attachment 434230 [details]
File: backtrace
Comment 2 tomek.by 2010-07-25 11:11:00 EDT
Package: wine-core-1.2.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. open windows 7 installer
2. click "Install now"
Comment 3 Matt Hooper 2010-07-25 19:28:27 EDT
Package: wine-core-1.2.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Run Wine and it crashes
2.
3.
Comment 4 Harald Hoyer 2010-07-28 12:35:09 EDT
*** Bug 618931 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2010-07-28 12:36:23 EDT
Created attachment 435069 [details]
fix for the segfault
Comment 6 Fedora Update System 2010-07-30 05:07:36 EDT
wine-1.2.0-2.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/wine-1.2.0-2.fc14
Comment 7 Fedora Update System 2010-07-30 05:08:38 EDT
wine-1.2.0-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/wine-1.2.0-2.fc13
Comment 8 Fedora Update System 2010-07-30 05:10:10 EDT
wine-1.2.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wine-1.2.0-2.fc12
Comment 9 Bug Zapper 2010-07-30 08:49:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 dominique 2010-07-30 13:26:58 EDT
(In reply to comment #6)
> wine-1.2.0-2.fc14 has been submitted as an update for Fedora 14.
> http://admin.fedoraproject.org/updates/wine-1.2.0-2.fc14    

I install wine-1.2.0.2.fc14 on my rawhide and that work fine... (I have no segmentation fault)

Thank for tnis update
Comment 11 Fedora Update System 2010-07-30 17:18:01 EDT
wine-1.2.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-2.fc14
Comment 12 Matt Hooper 2010-08-10 20:12:37 EDT
Package: wine-core-1.2.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


Comment
-----
Try to run IE6 for Linux
Comment 13 Fedora Update System 2010-08-18 21:25:48 EDT
wine-1.2.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-08-19 21:49:20 EDT
wine-1.2.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-08-19 22:15:00 EDT
wine-1.2.0-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.