Bug 617971 - file /usr/lib/debug/usr/lib/gstreamer-0.10/libgstschro.so.debug provided by more than one package
Summary: file /usr/lib/debug/usr/lib/gstreamer-0.10/libgstschro.so.debug provided by m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: schroedinger
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-25 10:56 UTC by Damian Wrobel
Modified: 2010-07-30 08:43 UTC (History)
3 users (show)

Fixed In Version: schroedinger-1.0.8-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-30 08:43:17 UTC
Type: ---


Attachments (Terms of Use)

Description Damian Wrobel 2010-07-25 10:56:28 UTC
Description of problem:
file /usr/lib/debug/usr/lib/gstreamer-0.10/libgstschro.so.debug from install of gstreamer-plugins-bad-free-debuginfo-0.10.19-1.fc12.i686 conflicts with file from package schroedinger-debuginfo-1.0.8-3.fc12.i686

Version-Release number of selected component (if applicable):

$ rpm -qa | grep debug | sort
alsa-lib-debuginfo-1.0.23-1.fc12.i686
alsa-plugins-debuginfo-1.0.22-1.fc12.i686
atk-debuginfo-1.28.0-1.fc12.i686
avahi-debuginfo-0.6.25-7.fc12.i686
bug-buddy-debuginfo-2.26.0-2.fc11.i586
bzip2-debuginfo-1.0.5-6.fc12.i686
cairo-debuginfo-1.8.8-3.fc12.i686
ccache-debuginfo-2.4-16.fc12.i686
cpio-debuginfo-2.10-5.fc12.i686
cyrus-sasl-debuginfo-2.1.23-9.fc12.i686
dbus-debuginfo-1.2.16-9.fc12.i686
dbus-glib-debuginfo-0.86-1.fc12.i686
dirac-debuginfo-1.0.2-3.fc12.i686
djbfft-debuginfo-0.76-6.fc8.i386
dpkg-debuginfo-1.15.5.6-4.fc12.i686
e2fsprogs-debuginfo-1.41.9-7.fc12.i686
elfutils-debuginfo-0.148-1.fc12.i686
expat-debuginfo-2.0.1-8.fc12.i686
faad2-debuginfo-2.7-1.fc11.i586
fakeroot-debuginfo-1.12.2-22.fc12.i686
ffmpeg-debuginfo-0.6-0.1.20100425svn.fc12.i686
flac-debuginfo-1.2.1-6.fc12.i686
fontconfig-debuginfo-2.8.0-1.fc12.i686
freetype-debuginfo-2.3.11-3.fc12.i686
gamin-debuginfo-0.1.10-5.fc12.i686
gcc-debuginfo-4.4.4-10.fc12.i686
GConf2-debuginfo-2.28.0-4.fc12.2.i686
gdb-debuginfo-7.1-25.fc12.i686
gdbm-debuginfo-1.8.0-33.fc12.i686
glib2-debuginfo-2.22.5-1.fc12.i686
glibc-debuginfo-2.11.2-1.i686
gmp-debuginfo-4.3.1-5.fc12.i686
gnome-user-share-debuginfo-2.28.2-2.fc12.i686
gsm-debuginfo-1.0.13-2.fc12.i686
gssdp-debuginfo-0.7.1-1.fc12.i686
gstbproxy-debuginfo-2.1.9-1.fc12.i686
gstreamer-debuginfo-0.10.29-1.fc12.i686
gtk2-debuginfo-2.18.9-3.fc12.i686
gtk-nodoka-engine-debuginfo-0.7.2-8.fc12.i686
gupnp-av-debuginfo-0.5.4-1.fc12.i686
gupnp-debuginfo-0.13.2-1.fc12.i686
jack-audio-connection-kit-debuginfo-0.118.0-1.fc12.i686
kernel-debuginfo-common-i686-2.6.32.16-141.fc12.i686
kernel-PAE-debuginfo-2.6.32.16-141.fc12.i686
krb5-debuginfo-1.7.1-9.fc12.i686
lame-debuginfo-3.98.3-1.fc12.1.i686
libasyncns-debuginfo-0.8-1.fc12.i686
libcap-debuginfo-2.16-5.fc12.i686
libcap-ng-debuginfo-0.6.2-3.fc12.i686
libdmpeg2_bh_plugin-debuginfo-2.0.2-2.fc9.i686
libdrm-debuginfo-2.4.18-2.fc12.i686
libgee-debuginfo-0.5.1-1.fc12.i686
libICE-debuginfo-1.0.6-1.fc12.i686
libidn-debuginfo-1.9-5.i686
libjpeg-debuginfo-6b-46.fc12.i686
libmp4v2-debuginfo-1.5.0.1-10.fc12.i686
libogg-debuginfo-1.1.4-2.fc12.i686
liboil-debuginfo-0.3.16-4.fc12.i686
libpng-debuginfo-1.2.44-1.fc12.i686
libSM-debuginfo-1.1.0-7.fc12.i686
libsndfile-debuginfo-1.0.20-3.fc12.i686
libsoup-debuginfo-2.28.2-1.fc12.i686
libstb-debuginfo-1.0.0-1.fc12.i686
libtheora-debuginfo-1.1.0-1.fc12.i686
libtiff-debuginfo-3.9.4-1.fc12.i686
libvdpau-debuginfo-0.4-1.fc12.i686
libvorbis-debuginfo-1.2.3-4.fc12.i686
libX11-debuginfo-1.3-1.fc12.i686
libXau-debuginfo-1.0.5-1.fc12.i686
libxcb-debuginfo-1.5-1.fc12.i686
libXcomposite-debuginfo-0.4.1-2.fc12.i686
libXcursor-debuginfo-1.1.10-1.fc12.i686
libXdamage-debuginfo-1.1.2-1.fc12.i686
libXdmcp-debuginfo-1.0.3-1.fc12.i686
libXext-debuginfo-1.1-2.fc12.i686
libXfixes-debuginfo-4.0.4-1.fc12.i686
libXi-debuginfo-1.3-2.fc12.i686
libXinerama-debuginfo-1.1-1.fc12.i686
libxml2-debuginfo-2.7.6-2.fc12.i686
libXrandr-debuginfo-1.3.0-5.fc12.i686
libXrender-debuginfo-0.9.5-1.fc12.i686
libXtst-debuginfo-1.0.99.2-3.fc12.i686
libXxf86vm-debuginfo-1.1.0-1.fc12.i686
make-debuginfo-3.81.90-1.fc12.i686
mpeg2dec-debuginfo-0.5.1-4.fc10.i386
mpfr-debuginfo-2.4.1-5.fc12.i686
nspr-debuginfo-4.8.4-2.fc12.i686
nss-debuginfo-3.12.6-7.fc12.i686
openjpeg-debuginfo-1.3-6.fc12.i686
ORBit2-debuginfo-2.14.17-3.fc12.i686
pam-debuginfo-1.1.0-7.fc12.i686
pango-debuginfo-1.26.2-1.fc12.i686
pixman-debuginfo-0.16.6-1.fc12.i686
pulseaudio-debuginfo-0.9.21-5.fc12.i686
rygel-debuginfo-0.4.12-1.fc12.i686
schroedinger-debuginfo-1.0.8-3.fc12.i686
SDL-debuginfo-1.2.13-11.fc12.i686
speex-debuginfo-1.2-0.12.rc1.fc12.i686
sqlite-debuginfo-3.6.20-1.fc12.i686
tcp_wrappers-debuginfo-7.6-56.fc12.i686
util-linux-ng-debuginfo-2.16.2-9.fc12.i686
vdpauinfo-debuginfo-0.0.6-2.fc12.i686
x264-debuginfo-0.0.0-0.27.20091109git3daa02e.fc12.i686
xvidcore-debuginfo-1.2.1-3.fc12.i686
yum-plugin-auto-update-debug-info-1.1.26-1.fc12.noarch
zlib-debuginfo-1.2.3-23.fc12.i686

How reproducible:
100%

Steps to Reproduce:
debuginfo-install ffmpeg-libs-0.6-1.fc12.i686 gnutls-2.8.6-2.fc12.i686 gstreamer-ffmpeg-0.10.10-1.fc12.1.i686 gstreamer-plugins-bad-free-0.10.19-1.fc12.i686 gstreamer-plugins-base-0.10.29-1.fc12.i686 gstreamer-plugins-good-0.10.23-1.fc12.i686 gvfs-1.4.3-7.fc12.i686 libgcrypt-1.4.4-8.fc12.i686 libgpg-error-1.6-4.i686 libselinux-2.0.90-5.fc12.i686 libtasn1-2.3-1.fc12.i686 libudev-145-21.fc12.i686
  
Actual results:
Transaction Check Error:
  file /usr/lib/debug/usr/lib/gstreamer-0.10/libgstschro.so.debug from install of gstreamer-plugins-bad-free-debuginfo-0.10.19-1.fc12.i686 conflicts with file from package schroedinger-debuginfo-1.0.8-3.fc12.i686

Expected results:
Debug-info should be installed without conflicts.


Additional info:
FC12 fully updated.

Comment 1 Nicolas Chauvet (kwizart) 2010-07-25 11:09:31 UTC
We are at schroedinger-1.0.8-4.fc12 in F-12. The diffence betwean release 3 and 4 is exactly the removal of the gst plugin from schroedinger package.

I would suggest to use yum-plugin-auto-update-debug-info.

Comment 2 Damian Wrobel 2010-07-25 12:13:05 UTC
(In reply to comment #1)
> I would suggest to use yum-plugin-auto-update-debug-info.    
I have this plugin enabled, but it looks that the aforementioned version is not available even in the updates-testing repository:

$yum update --enablerepo=updates-testing schroedinger
No Packages marked for Update

Comment 3 Damian Wrobel 2010-07-25 12:37:41 UTC
It looks that is was never built for F-12: http://koji.fedoraproject.org/koji/packageinfo?packageID=4558

Comment 4 Fabian Deutsch 2010-07-25 12:57:15 UTC
I did not realize that F-12 is still supported, when building the last package.

So it seems as if pushing 1.0.9-2 to F-12 should solve the problem.

Comment 5 Fabian Deutsch 2010-07-25 13:06:50 UTC
The problem is, that 1.0.9 depends on orc, which is not present in F-12.

Comment 6 Nicolas Chauvet (kwizart) 2010-07-25 13:40:41 UTC
schroedinger-1.0.8-4.fc12 has been requested to build for F-12,
I was probably waiting for gstreamer-plugins-bad-free to hit stable given that it has proper obsoleted for the schroedinger-gst-plugin, but not the related debuginfo package...

Comment 7 Fedora Update System 2010-07-25 13:45:32 UTC
schroedinger-1.0.8-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/schroedinger-1.0.8-4.fc12

Comment 8 Fedora Update System 2010-07-27 02:38:14 UTC
schroedinger-1.0.8-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update schroedinger'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/schroedinger-1.0.8-4.fc12

Comment 9 Fedora Update System 2010-07-30 08:43:12 UTC
schroedinger-1.0.8-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.