Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 617976 - GDB debuginfo installation suggestion does not work
GDB debuginfo installation suggestion does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-release-server (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
:
Depends On: 617162
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-25 07:27 EDT by Jan Kratochvil
Modified: 2010-11-11 11:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:22:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2010-07-25 07:27:32 EDT
Description of problem:
GDB in some cases suggests command to install debuginfo expecting debuginfo repositories are named '*-debuginfo' (since Bug 554152).  They are not named so in RHEL-6.  Such suggested command will fail for the user.
ABRT does not seem to be affected by this issue.

Version-Release number of selected component (if applicable):
redhat-release-server-6-6.0.0.27.el6.s390x

How reproducible:
Always.

Steps to Reproduce:
(ulimit -c unlimited;sleep 1h&p=$!;sleep 1;kill -SEGV $p);sleep 5;gdb -c ./core.*
# That curious `sleep 5' is there due to unrelated Bug 584554.
It prints:
Try: yum --disablerepo='*' --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/95/660a4802f4874ec0e20f216505e1015b82baab
so run it.
+
Also run:
repoquery -qf /usr/lib/debug/.build-id/95/660a4802f4874ec0e20f216505e1015b82baab

Actual results:
Loaded plugins: auto-update-debuginfo, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
No package /usr/lib/debug/.build-id/95/660a4802f4874ec0e20f216505e1015b82baab available.
Error: Nothing to do
+
coreutils-debuginfo-0:8.4-9.el6.s390x

Expected results:
Installing:
 coreutils-debuginfo s390x 8.4-9.el6 rhel6-debug 2.8 M
Total download size: 2.8 M
Installed size: 14 M
Is this ok [y/N]: 
+
coreutils-debuginfo-0:8.4-9.el6.s390x

Additional info:
Fedora always has debuginfo repositories named SMTH-debuginfo.
RHEL-6 has:
$ grep '^\[' /etc/yum.repos.d/rhel-debuginfo.repo
[rhel-debuginfo-beta]
[rhel-debuginfo-beta-optional]
$ rpm -qf /etc/yum.repos.d/rhel-debuginfo.repo
redhat-release-server-6-6.0.0.27.el6.s390x
$ rpm -V redhat-release-server-6-6.0.0.27.el6.s390x
This is a regression against Fedora releases.

This bug may need to be cloned for the other many RHEL-6 release variants.

abrt-1.1.10-2.el6:
src/Daemon/abrt-debuginfo-install:
#// Disabled. Too often, debuginfo repos have names which do not conform to "foo-debuginfo" scheme,
#// and users get bad backtraces.
yum_repo_opts="$yum_repo_opts '--enablerepo=*-debug*'"

This rule should be the same for both GDB and ABRT.
The question is whether *-release rpms or GDB should be changed.
Ccing also the default ABRT Cc list.
Comment 1 Jiri Moskovcak 2010-07-26 07:11:18 EDT
seems like clone of:
Summary: debuginfo-install works only with repos named *-debuginfo-*
https://bugzilla.redhat.com/show_bug.cgi?id=617162 

Jirka
Comment 2 Jan Kratochvil 2010-07-26 07:18:21 EDT
Yes, the same issue, thanks.
I just now do not understand how that bug can be closed when the problem is not fixed.  Moreover that one is for yum-utils while I believe the `release' rpm should be fixed instead.
Comment 5 Jan Stodola 2010-08-30 10:42:35 EDT
[root@rtt6 ~]# yum repolist
Loaded plugins: rhnplugin
repo id                                                                                repo name                                                                                                         status
rhel-s390x-server-6                                                                    Red Hat Enterprise Linux Server (v. 6 for IBM System Z)                                                           3,057
rhel-s390x-server-6-debuginfo                                                          RHEL Server Debuginfo (v.6 for IBM System Z)                                                                      1,347
repolist: 4,404
[root@rtt6 ~]# (ulimit -c unlimited;sleep 1h&p=$! ;sleep 1;kill -SEGV $p);sleep 5;gdb -c ./core.*
Excess command line arguments ignored. (./core.1867 ...)
GNU gdb (GDB) Red Hat Enterprise Linux (7.1-29.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "s390x-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
"/root/core.1859": not in executable format: File format not recognized
Missing separate debuginfo for the main executable file
Try: yum --disablerepo='*' --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/95/660a4802f4874ec0e20f216505e1015b82baab
[New Thread 1755]
Core was generated by `sleep 1h'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000200000f0408 in ?? ()
(gdb) quit
[root@rtt6 ~]# yum --disablerepo='*' --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/95/660a4802f4874ec0e20f216505e1015b82baab
Loaded plugins: rhnplugin
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package coreutils-debuginfo.s390x 0:8.4-9.el6 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================================================================================
 Package                                              Arch                                   Version                                      Repository                                                      Size
===============================================================================================================================================================================================================
Installing:
 coreutils-debuginfo                                  s390x                                  8.4-9.el6                                    rhel-s390x-server-6-debuginfo                                  2.8 M

Transaction Summary
===============================================================================================================================================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 2.8 M
Installed size: 0  
Is this ok [y/N]: y
Downloading Packages:
coreutils-debuginfo-8.4-9.el6.s390x.rpm                                                                                                                                                 | 2.8 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : coreutils-debuginfo-8.4-9.el6.s390x                                                                                                                                                     1/1 

Installed:
  coreutils-debuginfo.s390x 0:8.4-9.el6                                                                                                                                                                        

Complete!


Tested on build RHEL6.0-20100826.1 with redhat-release-server-6Server-6.0.0.35.el6.s390x.rpm. System registered into webdev.

Moving to VERIFIED.
Comment 6 releng-rhel@redhat.com 2010-11-11 11:22:41 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.