Bug 6180 - Php cgi version
Php cgi version
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-21 02:31 EDT by paulmatthews
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 21:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paulmatthews 1999-10-21 02:31:42 EDT
As part of the mod-php package a copy of php compiled for
cgi use should also be provided.

There are many occasions when you want cgi scripts to be run
as someone else other than the apache or nobody user for
security reasons.

A stand alone cgi version of php is required. (mod_php
cannot su to another user as it IS the apache process)
Comment 1 Milan Kerslager 2000-01-03 10:32:59 EST
I vote for php standalone iterpretter too. There should be SuExec mechanism
enabled in Apache too to take benefit from this package.
Comment 2 Preston Brown 2000-01-18 15:47:59 EST
suexec has been added to apache.

We simply don't have room (believe it!) on the CD to add another PHP binary.
This one you'll have to build yourself.  90+% of php users don't mind.
Comment 3 Nalin Dahyabhai 2000-06-27 21:41:06 EDT
This will be fixed in the next release.

Note You need to log in before you can comment on or make changes to this bug.