Bug 618104 - /Ddefine= does not work, unlike native version.
/Ddefine= does not work, unlike native version.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mingw32-nsis (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 02:44 EDT by Hin-Tak Leung
Modified: 2010-07-26 05:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 03:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2010-07-26 02:44:41 EDT
Description of problem:

Native makensis supports defines via /Ddefine=value and -Ddefine=value, whereas the mingw32-nsis only does -Ddefine=value . /Ddefine=value 
result in error messages like 

Can't open script "/DVERSION=9.00"

Version-Release number of selected component (if applicable):
mingw32-nsis-2.45-3.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. Just try one of the examples with /Dsomething= vs -Dsomething=
2.
3.
  
Actual results:


Expected results:


Additional info:
Both dashes and slashes are supposed to be suported since 2.25 in upstream.
Comment 1 Kevin Kofler 2010-07-26 03:12:42 EDT
Slashes as option characters only make sense on platforms which don't use it as path separators. As such, upstream only supports them for native builds. Dashes are supported everywhere.
Comment 2 Richard W.M. Jones 2010-07-26 05:46:34 EDT
I think is at best only a marginal bug.

In any case, it's something that the reporter should pursue with
the upstream NSIS project.  We don't change the option handling
ability of NSIS in any way compared to upstream, AFAIK.
Comment 3 Kevin Kofler 2010-07-26 05:51:02 EDT
Indeed we don't. This is exactly how things work upstream.

Note You need to log in before you can comment on or make changes to this bug.