Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 618111 - SELinux is preventing /usr/libexec/dovecot/imap "read" access on Maildir.
SELinux is preventing /usr/libexec/dovecot/imap "read" access on Maildir.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:7b5fbb26030...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 03:04 EDT by Clinton Work
Modified: 2010-07-26 15:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 06:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clinton Work 2010-07-26 03:04:38 EDT
Summary:

SELinux is preventing /usr/libexec/dovecot/imap "read" access on Maildir.

Detailed Description:

SELinux denied access requested by imap. It is not expected that this access is
required by imap and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:dovecot_t:s0
Target Context                unconfined_u:object_r:home_root_t:s0
Target Objects                Maildir [ dir ]
Source                        imap
Source Path                   /usr/libexec/dovecot/imap
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dovecot-1.2.12-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-39.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.6-147.fc13.i686.PAE #1 SMP Tue Jul 6
                              22:24:44 UTC 2010 i686 i686
Alert Count                   8
First Seen                    Mon 26 Jul 2010 12:53:42 AM MDT
Last Seen                     Mon 26 Jul 2010 12:53:43 AM MDT
Local ID                      5916e037-3d96-48fc-9fe0-6f03cfa11fc5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1280127223.12:27619): avc:  denied  { read } for  pid=4901 comm="imap" name="Maildir" dev=dm-0 ino=16122256 scontext=unconfined_u:system_r:dovecot_t:s0 tcontext=unconfined_u:object_r:home_root_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1280127223.12:27619): arch=40000003 syscall=33 success=no exit=-13 a0=980ab38 a1=4 a2=980ab38 a3=4 items=0 ppid=4541 pid=4901 auid=500 uid=600 gid=600 euid=600 suid=600 fsuid=600 egid=600 sgid=600 fsgid=600 tty=(none) ses=1 comm="imap" exe="/usr/libexec/dovecot/imap" subj=unconfined_u:system_r:dovecot_t:s0 key=(null)



Hash String generated from  catchall,imap,dovecot_t,home_root_t,dir,read
audit2allow suggests:

#============= dovecot_t ==============
allow dovecot_t home_root_t:dir read;
Comment 1 Miroslav Grepl 2010-07-26 06:59:46 EDT
Looks like a labeling problem. Where is Maildir located?

Try to execute:

restorecon -R -v /path_to/Maildir


Please reopen if the problem still persists.
Comment 2 Clinton Work 2010-07-26 15:58:35 EDT
I'm using postfix with maildrop to use Maildir style mailboxes in each users home directory.  For example:  

/home/clinton/Maildir

I'll try restorecon -R -v on /home and see how it works:  
restorecon -R -v /home

Note You need to log in before you can comment on or make changes to this bug.