Bug 618116 - expose state of driver load failure to user
Summary: expose state of driver load failure to user
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: 7.0
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2010-07-26 07:38 UTC by Jon Masters
Modified: 2014-07-17 13:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 13:25:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Masters 2010-07-26 07:38:30 UTC
Description of problem:

In the future, let's add support for informing the user that a driver failed to load because it was incompatible. All we need to do is detect the udev/modprobe/kernel message and inform the user that a driver update they pulled in was incompatible. It would be easier than silently failing if compatibility issues exist. I can help to implement this, but let's have a bug.

Comment 1 David Cantrell 2011-06-13 14:56:17 UTC
Would it be sufficient to capture the modprobe stderr and display that in a dialog box to the user?

Comment 2 RHEL Product and Program Management 2011-06-13 15:09:54 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 3 Martin Sivák 2011-06-17 15:31:52 UTC
John, how do you expect this to work in udev controlled environment?

Comment 4 Martin Sivák 2011-06-17 15:34:27 UTC
Do you know where we can get and how do we filter the relevant messages and status?

This might be better solved directly in depmod during the proposed driver version solving (which we will probably talk about some time very soon).

Comment 8 Jon Masters 2011-12-13 10:35:58 UTC
Firstly, I would like to decrease the priority on this bug. It is not a trivial implementation, and I think perhaps best left to 7.0 at this rate.

My suggestion is that you could:

1). Determine ehether no modules were loaded/changed after udev ran. Iterate over all sysfs module directories, take the module srcversion hashes, note that nothing changed. Or that something did. That tells you what happened.

2). If nothing happened, provide the user with the kernel log messages since the kernel itself will report on symbols that failed to resolve, etc. You could go digging for the modprobe output, but as David says, that gets tricky. Since it's unexpected that this will fail, I think it's reasonable to only output the end of the kernel log messages. That is better than nothing, and useful for debugging.

3). If a module disappeared (because it was going to be replaced but the replacement was incompatible) then you can additionally know exactly what the module that failed was called, and where it came from.

Jon.

Comment 12 RHEL Product and Program Management 2014-07-17 13:25:50 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.