Bug 618133 - RFE: anaconda should better support btrfs subvolumes
RFE: anaconda should better support btrfs subvolumes
Status: CLOSED DUPLICATE of bug 689517
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 04:43 EDT by Lubos Kocman
Modified: 2011-03-21 13:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-21 13:43:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2010-07-26 04:43:34 EDT
Hello,

I found that anaconda is missing support for some handy features of btrfs.

As you may know btrfs support subvolumes so it makes from btrfs something like lvm + filesystem at one (just like zfs). 

This makes user able to populate standart partition like /dev/sda1 and create rest of subvolumes in btrfs (linux lvm can be skipped).

So some checkbox to create subvolumes for standard mountpoints ( /home and /var ) would be really handy. This would be visible only if user selects btrfs based / filesystem.

How to create subvolume

btrfsctl -S home /
btrfsctl -S jack /home # creates subvolume jack under subvolume /home

This will create structure which is really easy to manage/backup in btrfs.
As we're able to create snapshots of filesystem or subvolumes but not directories nor files.

Also making subvolume for user picked up in installation process would be really nice.
Comment 1 Manuel Faux 2010-08-19 13:19:57 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Chris Lumens 2011-03-21 13:43:39 EDT

*** This bug has been marked as a duplicate of bug 689517 ***

Note You need to log in before you can comment on or make changes to this bug.